Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Comparison method violates its general contract!

  1. #1

    Default Comparison method violates its general contract!

    Hello all,

    I am running a kettle transformation on Kettle 4.4.0. The issue I am having with this is the i get the following error when running the transformation

    Exception in thread "Thread-32" java.lang.IllegalArgumentException: Comparison m
    ethod violates its general contract!
    at java.util.TimSort.mergeLo(TimSort.java:747)
    at java.util.TimSort.mergeAt(TimSort.java:483)
    at java.util.TimSort.mergeForceCollapse(TimSort.java:426)
    at java.util.TimSort.sort(TimSort.java:223)
    at java.util.TimSort.sort(TimSort.java:173)
    at java.util.Arrays.sort(Arrays.java:659)
    at java.util.Collections.sort(Collections.java:217)
    at org.pentaho.di.trans.TransMeta.sortStepsNatural(TransMeta.java:4253)
    at org.pentaho.di.trans.Trans.prepareExecution(Trans.java:578)
    at org.pentaho.di.ui.spoon.trans.TransGraph$22.run(TransGraph.java:3652)

    at java.lang.Thread.run(Thread.java:744)

    This issue only happens when I run the transformation. When I run the job that holds this transformation, the transformation runs fine.
    Does anyone have any experience with this error and what causes it. Some extra information the job is on a server, but I can run it locally with no issues,
    just on the server I get this error.

    Thank you

  2. #2
    Join Date
    Jun 2012
    Posts
    5,534

    Default

    I bet you have different Java installations locally and on the server.
    So long, and thanks for all the fish.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.