Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: ISSUE: PRPT CDA Datasource issue from within PUC

  1. #1
    Join Date
    Apr 2012
    Posts
    253

    Default ISSUE: PRPT CDA Datasource issue from within PUC

    The PRD preview works fine, wasn't sure if this should go in BI Server,CTools or here.

    When trying to view a PRPT with a CDA datasource with "Allow local API calls instead of HTTP calls" checked, the call to CDA fails

    Caused by: org.pentaho.reporting.engine.classic.core.ReportDataFactoryException: Failed to acquire cda plugin:
    at org.pentaho.reporting.platform.plugin.connection.CdaPluginLocalQueryBackend.callPlugin(CdaPluginLocalQueryBackend.java:146)
    at org.pentaho.reporting.platform.plugin.connection.CdaPluginLocalQueryBackend.fetchData(CdaPluginLocalQueryBackend.java:73)
    ... 86 more
    Caused by: java.lang.NoSuchMethodException: pt.webdetails.cda.CdaUtils.listParameters(java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, javax.servlet.http.HttpServletResponse, javax.servlet.http.HttpServletRequest)
    at java.lang.Class.getMethod(Class.java:1607)
    at org.pentaho.reporting.platform.plugin.connection.CdaPluginLocalQueryBackend.callPlugin(CdaPluginLocalQueryBackend.java:106)
    ... 87 more

  2. #2
    Join Date
    Nov 2011
    Posts
    1,229

    Default

    Actually that's a bug on the 5.0 EE codeline http://jira.pentaho.com/browse/PRD-4767

    It'll be definitely fixed for 5.1. But it should work fine with 5.0.1 CE.
    You should be able to use local API calls.
    Pedro Vale
    --
    CTools Product Development
    http://www.webdetails.pt

  3. #3
    Join Date
    Apr 2012
    Posts
    253

    Default

    Quote Originally Posted by pamval View Post
    Actually that's a bug on the 5.0 EE codeline http://jira.pentaho.com/browse/PRD-4767

    It'll be definitely fixed for 5.1. But it should work fine with 5.0.1 CE.
    You should be able to use local API calls.
    API Calls work now. But they do not work with Hidden Parameters on reports. I'm also running into issues with Scheduling non-api calls and hidden parameters in reports.

    I'm not sure what the issue is. The schedule will work fine for some time then just start bombing out with 501s when using the web calls.

    I was hoping to use the API calls to possibly fix the issue, but (note above) they do not work with hidden parameters.

    I'm pushing a JIRA.

  4. #4
    Join Date
    Apr 2012
    Posts
    253

    Default

    Thanks for the update Pedro.

    http://jira.pentaho.com/browse/PRD-5415

    So it won't be fixed until 5.4.

    I'd use non-api calls, but I've been running into scheduler issues with those. Broken pipes. The scheduled reports
    run for awhile then seem to become corrupted. I'm going to do another test with 5.3 to see if that is actually another
    issue or if it's been fixed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.