Hitachi Vantara Pentaho Community Forums
Results 1 to 7 of 7

Thread: Des Pentaho support Excel 2010

  1. #1

    Default Des Pentaho support Excel 2010

    Hi,

    I need to load data from Excel 2010. However, Excel input is not able to read the file.

    I have tried changing content to Excel 2007 XLSX (Apache POI).

    Do we have support for Excel 2010 in Pentaho. If no, can anyone please suggest other options. I also tried to rename the file to xls extension but it still didnt work.

    Thanks in advance.
    Best Regards,
    Neeta Chander

  2. #2
    Join Date
    Apr 2008
    Posts
    1,771

    Default

    Renaming a file does not convert it!
    As far as I know, PDI supports Excel 2010.

    Have you got any error message?
    Can you attach your Excel file?
    -- Mick --

  3. #3

    Default

    Thanks for your reply Mick...I was trying to attach my file but I was not able to. This site gave an error "invalid File". I also tried attaching another sample sheet with only 2-3 rows. That also didnt get attached with the error "Invalid File".

    I am using Kettle 4.4.0 and Microsoft Office professional plus 2010 (Excel 14.0.4760.1000 )

  4. #4
    Join Date
    Apr 2008
    Posts
    1,771

    Default

    Maybe you can zip the file and attach the zip?
    But I'm already on PDI 5.01 and they have updated the Excel Input step, so I doubt I can test your file properly.
    Can you attach a transformation with your Excel Input step and the file that you are trying to read?
    -- Mick --

  5. #5

    Default

    Attaching sample excel with ony 2 fields. Transformation is basic with Microsoft Excel Input. I have changed the content to Excel 2007 and when i click on get sheets, it does not return any sheet.

    Thanks.
    Attached Files Attached Files

  6. #6
    Join Date
    Apr 2008
    Posts
    1,771

    Default

    Just tested and it works fine.
    You need to do few steps in the correct sequence.
    1. select the "spread sheet type"
    2. browse to your file and click on ADD, so that the file appears in the grid of the "Files" tab
    3. check your options in the tab "content"
    4. in the tab "sheets" click on Get Sheetname(S)"

    It should work!
    -- Mick --

  7. #7

    Default

    Thanks Mick for your precious time...I am really sorry I did not think I need to add the file...thanks a ton

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.