Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Kettle / Spoon Database Connection - change character set of JDBC driver

  1. #1
    Join Date
    Jan 2014
    Posts
    11

    Default Kettle / Spoon Database Connection - change character set of JDBC driver

    Dear all

    we have a problem connecting Spoon and Report Designer to our Sybase ASE database. The connection itself works but when I test the connection I get this error message:

    Error connecting to database [test] : org.pentaho.di.core.exception.KettleDatabaseException:
    Error occured while trying to connect to the database
    Error connecting to database: (using class net.sourceforge.jtds.jdbc.Driver)
    Could not find a Java charset equivalent to DB charset roman9.
    org.pentaho.di.core.exception.KettleDatabaseException:
    Error occured while trying to connect to the database
    Error connecting to database: (using class net.sourceforge.jtds.jdbc.Driver)
    Could not find a Java charset equivalent to DB charset roman9.

    I read in some other forums and obviously I have to change the settings of the JDBC driver because the DB uses a from Windows not supported character set (roman9).

    In your driver’s user interface, go to the Advanced tab and select Client Default as your character set.

    Does anybody know how I can change the driver settings in Spoon / Kettle of Connection Type "SYBASE"?

    Thanks and best regards
    Michael



  2. #2
    Join Date
    Jun 2012
    Posts
    5,534

    Default

    When editing the connection options, select the Options in the left hand tree.
    jTDS supports a charset option.
    Most likely you will have to find a suitable ROMAN9 decoder, since this charset isn't part of any JDK.
    jCharset only comes with ROMAN8, but ROMAN9 added just the Euro currency symbol, I understand.
    Sybase is aware of the problem and listing ROMAN9 as an unsupported charset with respect to Java connectivity.
    So long, and thanks for all the fish.

  3. #3
    Join Date
    Jan 2014
    Posts
    11

    Default sybase connection

    thanks for letting me know, this seems tomwork now.

    would you mind check my second problem here relating to the jdts driver

    http://forums.pentaho.com/showthread...nect-to-Sybase

    thanks a lot for your help!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.