Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Error while setting up Pentaho 5.0 in eclipse

  1. #1
    Join Date
    Jan 2014
    Posts
    2

    Default Error while setting up Pentaho 5.0 in eclipse

    Hi All,

    As suggested I downloded Pentaho 5.0 code from github and now trying to run build.xml file with target clean-all, resolve but it is failing for resolve with following error

    Some projects fail to be resolved
    Impossible to resolve dependencies of ${ivy.artifact.group}#${ivy.artifact.id};${project.revision}
    unresolved dependency: pentaho-library#libfonts;${dependency.pentaho-reporting.revision}: not found
    unresolved dependency: ${dependency.reporting-engine.group}#pentaho-reporting-engine-classic-core;${dependency.pentaho-reporting.revision}: not found
    unresolved dependency: ${ivy.artifact.group}#kettle-core;${dependency.kettle.revision}: not found
    unresolved dependency: pentaho#metastore;${dependency.pentaho-metastore.revision}: not found
    unresolved dependency: pentaho#pentaho-registry;${dependency.pentaho-registry.revision}: not found
    unresolved dependency: pentaho#mondrian;${dependency.mondrian.revision}: not found
    Impossible to resolve dependencies of ${ivy.artifact.group}#${ivy.artifact.id};${project.revision}
    unresolved dependency: pentaho-library#libfonts;${dependency.pentaho-reporting.revision}: not found
    unresolved dependency: ${dependency.reporting-engine.group}#pentaho-reporting-engine-classic-core;${dependency.pentaho-reporting.revision}: not found
    unresolved dependency: ${ivy.artifact.group}#kettle-core;${dependency.kettle.revision}: not found
    unresolved dependency: pentaho#metastore;${dependency.pentaho-metastore.revision}: not found
    unresolved dependency: pentaho#pentaho-registry;${dependency.pentaho-registry.revision}: not found
    unresolved dependency: pentaho#mondrian;${dependency.mondrian.revision}: not found

    Can somebody please help me here?

  2. #2
    Join Date
    Dec 2013
    Posts
    11

    Default

    Hello

    I have recently encountered a similar problem

    It's because IVY can not get dependency component
    try to
    1.delete all files and folders in C:\Users\your_user_name\.ivy2\cache\
    2.delete all files that file name contains "pentaho" in C:\Users\your_user_name\.ivy2\resol-cache${env.EXECUTOR_NUMBER}

    for refer
    I also installed following plugin on my environment
    Apache Ivy 2.3.0.final_20130110142753
    Apache Ivy Ant Tasks 2.3.0.final_20130110142753
    Apache IvyDE 2.2.0.final-201311091524-RELEASE
    Apache IvyDE Resolve Visualizer 2.2.0.final-201311091524-RELEASE

    Name:  螢幕擷取畫面_011614_091352_AM.jpg
Views: 184
Size:  24.2 KB

    good luck to you

  3. #3
    Join Date
    Mar 2003
    Posts
    8,085

    Default

    And if in doubt - ignore Eclipse, go to the command line and invoke Ant from there. The resolve step is a one time step and once you have the jars in the "lib" directories you can work with them normally, without having to worry about Ivy.
    Get the latest news and tips and tricks for Pentaho Reporting at the Pentaho Reporting Blog.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.