Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Mondrian stops returning data

  1. #1
    Join Date
    Mar 2009
    Posts
    205

    Default Mondrian stops returning data

    Very strange problem.

    We recently added a new schema to our application and we started noticing that our dashboards would stop returning data after a few runs. Backtracking, we were able to conclude that we had this problem before, but it did not happen really often.

    We have pentaho biserver 3.7 with mondrian 3.3xxx (we tried updating it to Mondrian 3.5 - same result).

    We use C-Tools CDA / CDF to retrieve data through MDX queries.


    If we flush CDA cache: same problem
    If we flush Mondrian cache: it start working again.

    There is no error message in the pentaho log.

    On weird thing is if we take an MDX statement that is not working through CDA and run it with jPivot, it works. I know both tools do not use the same method to access Mondrian, but I included this detail in case it matters.

    We tried to disable Mondrian caching either in the schema definition or in mondrian.properties, but we still get the same problem.

    Some new ideas would be greatly appreciated !

    Hugues

  2. #2
    Join Date
    Jan 2013
    Posts
    796

    Default

    I would try to narrow the problem down some. Does this happen with specific dimensions and measures, or across the board? If it does happen only with specific measures/dimensions, what's different between them and the elements that don't have this problem? You mention it doesn't happen with jPivot-- if you run one of the problematic queries twice in jPivot are you able to reproduce the caching issue?

  3. #3
    Join Date
    Mar 2009
    Posts
    205

    Default

    Thank you Matthew for the hints.

    We were able to narrow it down a little.

    We activated the Mondrian logs (mdx and SQL). After calling a few dashbords or CDA, we noticed that one of that MDX parameter was null in the MDX log, and in the SQL log, the hierarchy name was used int the WHERE clause instead of the actual value.

    One other stange fact is that after waiting 5 minutes approximately, it starts working again (nothing else is going on, on this test server). Maibe CDA automatically cleaning the Mondrian cache after this delay.

    A quick search in the forum lead to this jira issue:

    http://jira.pentaho.com/browse/MONDRIAN-1485

    I'd like to give mondrian 3.6.1 a try, but we cannot quickly upgrade to pentaho 5.0.1 and we are with CE Suite 4.1.

    Hugues
    Do you know if its possible ?

  4. #4
    Join Date
    Mar 2007
    Posts
    142

    Default

    Have you tried upgrading Mondrian and olap4j only? I think that APIs are still the same, so in theory it should work. I might be forgetting something though, so give it a try, run a bunch of queries and check the logs.
    Luc Boudreau
    aka. Luc le Magnifique
    aka. Monsieur Oui Oui

    Lead Engineer, Pentaho Corporation
    Web: http://devdonkey.blogspot.com
    Twitter: luclemagnifique
    IRC: Monsieur_Oui_Oui@freenode

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.