Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: No records written to Informix

  1. #1
    Join Date
    Oct 2012
    Posts
    10

    Question No records written to Informix

    I am having a problem with Kettle 5.0.1 writing to my Informix Database. I set up a Repository on Informix and I am able to create Transformations and then store them in the Repository without any problems. The issue starts when I attempt to write to the database via a Transformation. The Transformation runs without any errors but does not produce any output. As a test I was able to read from an existing table and output to a text file, but any attempt to write to a database table ends with no output although the appropriate number of records are read from the source. There are absolutely no records written to the table. Does anyone have any insight into this problem?


    Spoon Release - 5.0.1-stable
    Java Version "1.7.0_51"
    Informix 11.50.FC6
    Windows7 64-bit / Core i5 8GB

  2. #2
    Join Date
    Jun 2012
    Posts
    5,534

    Default

    Quote Originally Posted by Munimula View Post
    There are absolutely no records written to the table.
    Or they are written but not committed.

    BTW: You try to write to your Kettle configuration database!?.
    What happens if you write to a different database connection?
    So long, and thanks for all the fish.

  3. #3
    Join Date
    Oct 2012
    Posts
    10

    Default

    I have finally had some time to investigating the problem that I was having with Kettle and Informix 11.50. It seems that I am having a problem with "Truncate table" not working in the Table Output Transformation. Whenever Truncate table is selected, Kettle does not successfully insert records into the database table. If I leave the commit size to 1000, Kettle will not insert any of the 4 records in the test file input into the table. If I set commit size to 1, Kettle will insert 3 records. If I do not select "Truncate table" Kettle will insert the records correctly.
    I have been using "Truncate table" during development and testing of Jobs that I am doing using Microsoft MSSQL Server and it work correctly . I am not sure why Kettle does not work correctly with Informix, could it be a bug? Does anyone have in insight into this issue?

  4. #4
    Join Date
    Feb 2014
    Posts
    4

    Default

    Quote Originally Posted by Munimula View Post
    I am having a problem with Kettle 5.0.1 writing to my Informix Database. I set up a Repository on Informix and I am able to create Transformations and then store them in the Repository without any problems. The issue starts when I attempt to write to the database via a Transformation. The Transformation runs without any errors but does not produce any output. As a test I was able to read from an existing table and output to a text file, but any attempt to write to a database table ends with no output although the appropriate number of records are read from the source. There are absolutely no records written to the table. Does anyone have any insight into this problem?


    Spoon Release - 5.0.1-stable
    Java Version "1.7.0_51"
    Informix 11.50.FC6
    Windows7 64-bit / Core i5 8GB
    Me too, I am having a problem with Kettle 5.0.1

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.