Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: naive bayes unclassified instances

  1. #1
    Join Date
    Dec 2013
    Posts
    3

    Default naive bayes unclassified instances

    helo all,

    i have a problem with using a save model of naive bayes.
    i use a train data set with 10-folds cross validation and naive bayes classifier. after this, i saved the model.
    when i open a test set using the serializedclassifier with the saved model- not all the instances are classified, in addition i can't see the output probabilities because of this. what can be the reason that not all the instance are classified

    haviv/

  2. #2

    Default

    Hello haviv,
    i can only think of two things that could have happened:
    1st your database is not fully classified
    2nd you may have chosen the wrong attribute to be your class

    this is what i think could have happened since i once did some of this things.
    if i think of anything else i'll let you know

  3. #3
    Join Date
    Dec 2013
    Posts
    3

    Default

    Quote Originally Posted by oscar.picchi View Post
    Hello haviv,
    i can only think of two things that could have happened:
    1st your database is not fully classified
    2nd you may have chosen the wrong attribute to be your class

    this is what i think could have happened since i once did some of this things.
    if i think of anything else i'll let you know
    i check, but this is not the problem.in addition,even if i run reguar naive bayes on the test set(and not serialized from train), i get this result. it's possibale that the problem is that i have attributes that some of its values are unique(appears only in one record)?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.