Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Problem with space creating the JVM

  1. #1
    Join Date
    Feb 2014
    Posts
    16

    Question Problem with space creating the JVM

    Hi everyone!
    I have a problem when starting the biserver with start-pentaho.bat. When I try to execute it, it says something like:

    Error occurred during initialization of VM
    Could not reserve enough space for object heap
    Could not create the Java virtual machine.


    I searched on the Internet and tried two things but none of them are working for me.

    1. I start the server from "/tomcat/bin startup.bat". In this case, the server starts and I can access the locaklhost:8080/pentaho. But it goes really slow and when I want to save something I get an error and in the tomcat server it is possible to read something regarding the space problem. I tried to set the "initial memory pool" and "maximum memory pool" to higher numbers but still it does not work.

    2. I start the service with "/biserver-ce start-pentaho.bat" changing before the

    set CATALINA_OPTS=-Xms1024m -Xmx2048m -XX:MaxPermSize=256m to higher values just to check-> 2048, 4096 and 512

    But still I get an error with that.

    Anyone can give me a hint?
    Thanks in advance and kind regards,
    Alain

  2. #2
    Join Date
    Feb 2014
    Posts
    16

    Default

    Quote Originally Posted by alainflecha View Post
    Hi everyone!
    I have a problem when starting the biserver with start-pentaho.bat. When I try to execute it, it says something like:

    Error occurred during initialization of VM
    Could not reserve enough space for object heap
    Could not create the Java virtual machine.


    I searched on the Internet and tried two things but none of them are working for me.

    1. I start the server from "/tomcat/bin startup.bat". In this case, the server starts and I can access the locaklhost:8080/pentaho. But it goes really slow and when I want to save something I get an error and in the tomcat server it is possible to read something regarding the space problem. I tried to set the "initial memory pool" and "maximum memory pool" to higher numbers but still it does not work.

    2. I start the service with "/biserver-ce start-pentaho.bat" changing before the
    set CATALINA_OPTS=-Xms1024m -Xmx2048m -XX:MaxPermSize=256m to higher values just to check-> 2048, 4096 and 512

    But still I get an error with that.

    Anyone can give me a hint?
    Thanks in advance and kind regards,
    Alain

    Ok, I tried setting this way:

    set CATALINA_OPTS=-Xms256m -Xmx1024m -XX:MaxPermSize=256m -> (-Xmx does not allow me to set it to more than 1024, it crashes if so)

    I am able to launch start-pentaho.bat and access the web page but it is still really slow and I it does not respond properly.

    Any other ideas?

  3. #3
    Join Date
    Feb 2014
    Posts
    16

    Default

    Solved! It was a problem with java installation

    Sorry for the inconveniences!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.