Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Setting Minimal Width on Text File Output when field list unknown

  1. #1
    Join Date
    Mar 2014

    Default Setting Minimal Width on Text File Output when field list unknown

    We are just beginning development of our ETL infrastructure using Pentaho Data Integration 5.0.3 on Windows 2012 and have a job that pulls a list of source tables from a table that drives an extract and load into out data warehouse. The extract data step includes a Table Input step with the following variable based SQL:

    SQL: SELECT * FROM [${dw_data_source_schema}].dbo.[${dw_data_source_table}]
    Options: "replace variables in script" selected.

    The Table Input step is connected to a Text File Output step with only a FileName and Separator defined. We are hitting out of memory errors when we extract a SQL Server table that has a text data type defined. The error goes away if I move away from the variable driven SQL in the Table Input step and importing the field list for the problem tables and selecting the "minimal width" option.

    Is there a way to dynamically set the "minimum width" option of the text file output step at execution time?

    Thanks all for the feedback!

  2. #2
    Join Date
    Jun 2013


    I am also facing the same challenge of needing to extract many tables contents to text files dynamically. But there is not a way to have these set to minimum width that I can see.

    Any help is appreciated.


    Ross Meyer

  3. #3
    Join Date
    Jun 2012


    Why don't you all just enable option "Fast data dump" on the Content tab?
    So long, and thanks for all the fish.

  4. #4
    Join Date
    Jun 2013



    Thanks! That flag worked fine.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.