Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: mySQL Connection

  1. #1
    Join Date
    Feb 2014
    Posts
    14

    Unhappy mySQL Connection

    Hi,

    I'm trying to connect to a mySQL connection, I installed mySQL cluster and mysql-connector-odbc-5.2.6-win32.msi but surely I miss something (driver maybe? I don't know where and what to download)
    When I try to create a connection I get the error message attached.

    Thanks so much
    Attached Images Attached Images   
    Last edited by Shira; 03-20-2014 at 05:46 AM.

  2. #2
    Join Date
    Jun 2012
    Posts
    5,534

    Default

    Your MSI package doesn't know anything about Kettle and Kettle is looking for the driver in its folder libext/JDBC (in my version).
    So one easy way out of your problem is to grab the jar and copy it to this folder and restart Kettle.
    So long, and thanks for all the fish.

  3. #3
    Join Date
    Feb 2014
    Posts
    14

    Default

    Thanks! that was probably the problem, now I get an error: Unknown database 'myDBname', do I have to pre create the db? how?

  4. #4
    Join Date
    Feb 2014
    Posts
    14

    Default

    It works!! Thank you ever so much for your help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.