Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Error Scheduling a job in DI Server 5.0

  1. #1

    Exclamation Error Scheduling a job in DI Server 5.0

    HI All,


    I have scheduled some jobs in my pentaho DI Server. But every time they are running they are failing. The error i am getting is :

    UpdateStep - Dispatching started for transformation [UpdateStep]
    2014/04/06 22:57:56 - Table Input - ERROR (version 5.0.0.1, build 1 from 2013-09-11_16-51-19 by buildguy) : An error occurred, processing will be stopped:
    2014/04/06 22:57:56 - Table Input - Error occured while trying to connect to the database
    2014/04/06 22:57:56 - Table Input -
    2014/04/06 22:57:56 - Table Input - Driver class 'org.gjt.mm.mysql.Driver' could not be found, make sure the 'MySQL' driver (jar file) is installed.
    2014/04/06 22:57:56 - Table Input - org.gjt.mm.mysql.Driver
    2014/04/06 22:57:56 - UpdateStep - ERROR (version 5.0.0.1, build 1 from 2013-09-11_16-51-19 by buildguy) : Something went wrong while trying to stop the transformation: org.pentaho.di.core.exception.KettleDatabaseException:
    2014/04/06 22:57:56 - UpdateStep - Unable to get database metadata from this database connection
    2014/04/06 22:57:56 - UpdateStep - at java.lang.Thread.run (null:-1)
    2014/04/06 22:57:56 - UpdateStep - at org.pentaho.di.trans.step.StepInitThread.run (StepInitThread.java:65)
    2014/04/06 22:57:56 - UpdateStep - at org.pentaho.di.trans.steps.tableinput.TableInput.init (TableInput.java:363)
    2014/04/06 22:57:56 - UpdateStep - at org.pentaho.di.trans.step.BaseStep.stopAll (BaseStep.java:2605)
    2014/04/06 22:57:56 - UpdateStep - at org.pentaho.di.trans.Trans.stopAll (Trans.java:1729)
    2014/04/06 22:57:56 - UpdateStep - at org.pentaho.di.trans.steps.tableinput.TableInput.stopRunning (TableInput.java:303)
    2014/04/06 22:57:56 - UpdateStep - at org.pentaho.di.core.database.Database.cancelQuery (Database.java:640)
    2014/04/06 22:57:56 - UpdateStep - at org.pentaho.di.core.database.Database.getDatabaseMetaData (Database.java:2653)
    2014/04/06 22:57:56 - UpdateStep - ERROR (version 5.0.0.1, build 1 from 2013-09-11_16-51-19 by buildguy) : org.pentaho.di.core.exception.KettleDatabaseException:
    When i looked up to the logs i found that this is because of a missing driver. But the Jobs and the transformation are running the way they should when i am running them manually but the schedule aint working. I have placed the mysql-connector jar in the following paths:

    /usr/local/pentaho50/server/data-integration-server/tomcat/lib/mysql-connector-java-5.1.17.jar
    /usr/local/pentaho50/server/data-integration-server/tomcat/server/lib/mysql-connector-java-5.1.17.jar
    /usr/local/pentaho50/server/data-integration-server/tomcat/webapps/pentaho-di/WEB-INF/lib/mysql-connector-java-5.1.17.jar


    Should i place the jar in any other location. Please help me with this.

    Thanks,
    Santosh Bhagavatula

  2. #2
    Join Date
    Mar 2012
    Posts
    276

    Default

    Hi there,

    Facing similar issue , Jobs running fine from UI executions but issues with scheduling .

    Error :- Driver class 'org.gjt.mm.mysql.Driver' could not be found, make sure the 'MySQL' driver (jar file) is installed.


    Pentaho 5.0.1
    Windows

  3. #3
    Join Date
    Jun 2012
    Posts
    5,534

    Default

    Quote Originally Posted by santoshbhagavatula View Post
    Should i place the jar in any other location
    The documentation seems to be quite determined about the place.

    Did you restart DI-Server?
    So long, and thanks for all the fish.

  4. #4

    Default

    Hi Marabu,

    Thanks for looking on to this. The connection's which we are using are directly taken from 4.5(Old Connections) because of which we are getting a metadata error.
    Apologies i missed that part of the error log. Well Creating the connection again and using it solved the problem.

    Surya,

    If you are facing the same issue, This could probably be your solution.

    Cheers,
    Santosh Bhagavatula

  5. #5
    Join Date
    Mar 2012
    Posts
    276

    Default

    Thanks mate ,


    Its an meta data connection issue .all the drivers are in place .

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.