Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Disabling cache for Pentaho

  1. #1
    Join Date
    Jun 2013
    Posts
    4

    Default Disabling cache for Pentaho

    Hi

    I have a report for which the data source is a Mondrian cube. (biserver-ce version 4.8 - Report Designer 3.9.1 - Mondrian 3.5)


    In the Pentaho User console, I have noticed that whenever the underlying data for a report changes, I
    do not see the changes when I rerun the report.


    I have tried the following:


    1) If I go to "Tools --> Refresh --> Reporting Data Cache" and rerun the report I do not see the changes.
    2) If I go to "Tools --> Refresh --> Mondrian Schema Cache" and rerun the report I see the changes.
    3) In the report designer I have set "Master Report --> Attributes --> pentaho --> report-cache" value to false - still no refresh of the data.
    4) In the report designer I additionally set "Master Report --> Attributes --> query --> data-cache" value to false. - still no refresh of data.
    5) In the "\pentaho-solutions\system\mondrian\mondrian.properties" file, I set "mondrian.rolap.star.disableCaching=" to true - still no changes reflected.
    6) In "\tomcat\tomcat\webapps\pentaho\WEB-INF\classes\classic-engine.properties" file I added the line org.pentaho.reporting.engine.classic.core.cache.DataCache=


    The thing that finally works for me is to do both steps 5 & 6. Note that just step 5 or 6 independently does not give me the desired rseult.

    Is this the right way to do things? I have no idea what side effects these changes will have.


    Is there a better way of disabling cache on a per report basis - or just disable caching of data (without disabling cache for stuff other
    than data like meta data, mondrian schemas etc)


    Thanks in advance
    Vadi

  2. #2
    Join Date
    Apr 2014
    Posts
    1

    Default

    Hi,

    Got the same problem with a jpivot report. Expected to see the actual values, some historical ones.
    Is it easy to view actual values by default?

    Thanks in advance,
    Gerard

  3. #3
    Join Date
    Jun 2012
    Posts
    20

    Default

    I have had the same problem - I get data from a report via a mondrian cube but when the data in DB changes, it is not reflected in the report unless i logout and login again. (i have also set report-cache to false and also in the cube definition cache is set to false).

    Here is how i fixed it.

    1) in pentaho-solutions\system\mondrian\mondrian.properties" - set "mondrian.rolap.star.disableCaching=" to true
    2) in
    tomcat\tomcat\webapps\pentaho\WEB-INF\classes\classic-engine.properties add the line - org.pentaho.reporting.engine.classic.core.cache.DataCache=
    3) in
    tomcat\tomcat\webapps\pentaho\WEB-INF\classes\ehcache.xml for cache name "mondrian-catalog-cache" set timeToIdleSeconds and timeToLiveSeconds to a small value, say 5


    What is interesting is that if i do steps 1 and 2 it works for some reports, and for some reports just step 3 suffices. So for now i have done all three steps.

    I am not sure if this will work for you since this approach is based on trial and error rather an understanding of how ehcache works in in the pentaho+mondrian setup.

    So while it works for me , there is not a good feeling of comfort that this is the way to do it. Hopefully someone from the pentaho team can throw some light on this.

    regards
    -anish

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.