Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Couldn't find field during SCD type 2 implementation

  1. #1
    Join Date
    Mar 2014
    Posts
    181

    Default Couldn't find field during SCD type 2 implementation

    Hi everyone,

    I have a kettle transformation getting data from my landing to the persistent staging area.

    When i run the transformation to implement the SCD.

    It generates an error that it couldn't find field.

    I have attached both the transformation and logs.

    Thanks,

    Ron

  2. #2
    Join Date
    Mar 2014
    Posts
    181

    Default

    Gutlez,

    I do have this field, src_ord_submitted_dt in my input step but I just don't like how Kettle is behaving.

    Thanks,

    Ron

  3. #3
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    It has to do with the way that you have inlined the Execute SQL step.

    Note that you have no parameters for your SQL statement, so ALL records are being updated, not just the individual orders.
    You should really look at the Dimension Lookup / Update step, since it was designed to do SCD2.
    **THIS IS A SIGNATURE - IT GETS POSTED ON (ALMOST) EVERY POST**
    I'm no expert.
    Take my comments at your own risk.

    PDI user since PDI 3.1
    PDI on Windows 7 & Linux

    Please keep in mind (and this may not apply to this thread):
    No forum member is going to do your work for you. We will help you sort out how to do a specific part of the work, as best we can, in the timelines that our work will allow us.
    Signature Updated: 2014-06-30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.