Hitachi Vantara Pentaho Community Forums
Results 1 to 1 of 1

Thread: need help in 2: can't run a job from kitchen, and can't create a data base repository

  1. #1
    Join Date
    Mar 2014
    Posts
    1

    Default need help in 2: can't run a job from kitchen, and can't create a data base repository

    Hi, im despered at this moment, i have the following problems:
    1- i tried to run a job from kitchen and there is no way i can do it, this is my .bat file content, the .bat from kitchen and spoon has not been touch
    ###########################################
    set JAVA_HOME=C:\Pentaho\jre
    set KETTLE_HOME=C:\Pentaho\data-integration
    set KETTLE_DIR=C:\Pentaho\data-integration
    set hr=%time:~0,2%
    if "%hr:~0,1%" equ " " set hr=0%hr:~1,1%

    rem %KETTLE_DIR%\Kitchen.bat /file:%KETTLE_HOME%\Booking_Ratio\Booking_Ratio_Job.kjb /user:admin /pass:admin /logs/%filename%
    C:
    cd \Pentaho\data-integration
    call "Kitchen.bat" /rep:"C:\Producto\Pentaho\Repository" /job:"\Booking_Ratio_Job.kjb" /dir:"\Booking_Ratio" /user:admin /pass: /level:Basic > C:\Producto\Pentaho\logs\Kettlelog.log
    #######################################################
    2- i tried to créate a repository and it give me th following error. i tried to change the password, but i can't see th security tab en the repository. when i tried to enter th password, it give me an error
    org.pentaho.di.core.exception.KettleException:
    Error connecting to the repository!

    The version of the repository is -1.-1.
    This Kettle edition requires it to be at least version 5.0 and as such an upgrade is required.
    To upgrade, backup your database and export the repository to XML for additional safety.
    Then select the 'Edit' button followed by the 'Create or Upgrade' button.
    Please consult the Upgrade Guide for eventually special instructions for this version.

    at org.pentaho.di.repository.kdr.delegates.KettleDatabaseRepositoryConnectionDelegate.connect(KettleDatabaseRepositoryConnectionDelegate.java:165)
    at org.pentaho.di.repository.kdr.KettleDatabaseRepository.connect(KettleDatabaseRepository.java:194)
    at org.pentaho.di.repository.kdr.KettleDatabaseRepository.connect(KettleDatabaseRepository.java:180)
    at org.pentaho.di.ui.repository.RepositoriesHelper.loginToRepository(RepositoriesHelper.java:249)
    at org.pentaho.di.ui.repository.controllers.RepositoriesController$3.run(RepositoriesController.java:216)
    at java.lang.Thread.run(Thread.java:745)
    Caused by: org.pentaho.di.core.exception.KettleException:
    The version of the repository is -1.-1.
    This Kettle edition requires it to be at least version 5.0 and as such an upgrade is required.
    To upgrade, backup your database and export the repository to XML for additional safety.
    Then select the 'Edit' button followed by the 'Create or Upgrade' button.
    Please consult the Upgrade Guide for eventually special instructions for this version.
    at org.pentaho.di.repository.kdr.delegates.KettleDatabaseRepositoryConnectionDelegate.verifyVersion(KettleDatabaseRepositoryConnectionDelegate.java:217)
    at org.pentaho.di.repository.kdr.delegates.KettleDatabaseRepositoryConnectionDelegate.connect(KettleDatabaseRepositoryConnectionDelegate.java:145)
    ... 5 more
    Last edited by Paloalto; 05-01-2014 at 04:40 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.