Hitachi Vantara Pentaho Community Forums
Results 1 to 7 of 7

Thread: java Runtime enviorment 1.5.0 issue

  1. #1
    Join Date
    May 2013
    Posts
    19

    Default java Runtime enviorment 1.5.0 issue

    Hi All,

    we are using Kettle 3.2.0 version and installed java 1.6.0.45 in windows 64 bit machine. when we trying to open kettle application it is throwing issue like:- application requires a java Runtime enviorment 1.5.0. i am assuming kettle 3.2.0 version shoud work on java 1.6.0 as well.

    Could you please help regarding this., below are snap shots.

    Thank you Name:  kettle 3.2.0.jpg
Views: 182
Size:  15.9 KB Name:  java version.jpg
Views: 174
Size:  11.2 KB

  2. #2
    Join Date
    Oct 2010
    Posts
    369

    Default

    may be issue with java version, have you tried installing 1.5 and run kettle

  3. #3
    Join Date
    May 2013
    Posts
    19

    Default

    Thanks for your reply Lal Gourav.

    Actually we are using java 1.6.0.45 and few of other applications already running using this version example(Jboss and cognos 10.1.1 etc).

    As per my knowledge kettle 3.2.0 will work using java 1.6.0.45, in one of my server is working fine. I want to know how can we rectify exiting issue. please suggest me.

    Thanks,
    Ramireddy
    Last edited by Ramireddy; 06-10-2014 at 06:55 AM.

  4. #4
    Join Date
    Apr 2008
    Posts
    4,686

    Default

    Is there a particular reason that you're staying with 3.2.0?
    3.2.0 is VERY old.

    I'm able to run 3.1.0 Kettle.exe with JRE7 installed (No JRE5 nor JRE6)
    Do you have both JRE6-64bit and JRE6-32bit installed?
    **THIS IS A SIGNATURE - IT GETS POSTED ON (ALMOST) EVERY POST**
    I'm no expert.
    Take my comments at your own risk.

    PDI user since PDI 3.1
    PDI on Windows 7 & Linux

    Please keep in mind (and this may not apply to this thread):
    No forum member is going to do your work for you. We will help you sort out how to do a specific part of the work, as best we can, in the timelines that our work will allow us.
    Signature Updated: 2014-06-30

  5. #5
    Join Date
    May 2013
    Posts
    19

    Default

    Hi Qutlez,

    thanks for your reply, yes as per my PM's confirmation we are using 3.2 version. in my server jre6,jdk1.6.0_45 installed , below is the details. so are you suggesting me to install JRE6-32bit as well ?

    java version "1.6.0_45"
    Java(TM) SE Runtime Environment (build 1.6.0_45-b06)
    Java HotSpot(TM) 64-Bit Server VM (build 20.45-b01, mixed mode)

    Thank you
    Last edited by Ramireddy; 06-10-2014 at 06:54 AM.

  6. #6
    Join Date
    Apr 2008
    Posts
    4,686

    Default

    It won't hurt to install the 32bit JRE as well as the 64bit.

    I was able to run PDI3.1 on Windows 7 with JRE7-32bit, so it might work.
    **THIS IS A SIGNATURE - IT GETS POSTED ON (ALMOST) EVERY POST**
    I'm no expert.
    Take my comments at your own risk.

    PDI user since PDI 3.1
    PDI on Windows 7 & Linux

    Please keep in mind (and this may not apply to this thread):
    No forum member is going to do your work for you. We will help you sort out how to do a specific part of the work, as best we can, in the timelines that our work will allow us.
    Signature Updated: 2014-06-30

  7. #7
    Join Date
    May 2013
    Posts
    19

    Default

    Quote Originally Posted by gutlez View Post
    It won't hurt to install the 32bit JRE as well as the 64bit.

    I was able to run PDI3.1 on Windows 7 with JRE7-32bit, so it might work.
    I installed java run time environment 1.5.0, my kettle 3.2.0 version is working fine with my existing applications which were pointed to jre 1.6.45.

    Thank you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.