Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: pdi 5.1 and agile bi

  1. #1

    Default pdi 5.1 and agile bi

    I have tried to install on pdi 5.1 ( dowloaded from sourceforge => http://sourceforge.net/projects/pent...2.zip/download) the agile bi plugin ( downloaded from sourceforge => http://sourceforge.net/projects/pent...2.zip/download ) .
    My os is windows 7 32 bit with java version 1.7.0_65 .
    I have unzipped the pmv-5.1.0.0-752.zip and copied the agile-bi dir in data-integration\plugins .
    At this point i have started spoon but it does not start anymore ( it only visualize the splash screen ) .
    If i remove the dir agile-bi spoon work well .
    I have run spoon also from the dos command line but i can't see any error .
    Have i done something wrong ?
    Thanks for any answer ?

  2. #2
    Join Date
    Apr 2008
    Posts
    1,771

    Default

    I think that in PDI 5.1 you can install the Agile plug in using the Marketplace.
    Have you tried it?
    -- Mick --

  3. #3

    Default

    i have checked the marketplace òist of plugins but i have not find the agile plugin in it .


    anyway i have solved the problem copying the lib slf4j-api-1.7.3.jar and slf4j-log4j12-1.7.3.jar in /data-integration/plugins/agile-bi/lib/ .


    To display the error on the console i have run spoon with the command SpoonDebug.bat .


    Spoon now is working and however i get the error that follow :


    Launching Spoon: "E:\Programs\pentaho\pdi\bin\5.1.0\data-integration\spoon.bat" /levelebug
    Console output gets redirected to "E:\Programs\pentaho\pdi\bin\5.1.0\data-integration\SpoonDebug.txt"
    2014-09-19 10:54:13.553::INFO: Logging to STDERR via org.mortbay.log.StdErrLog
    2014-09-19 10:54:13.578::INFO: jetty-6.1.21
    2014-09-19 10:54:13.730::WARN: Web application not found plugins/spoon/agile-bi/platform/webapps/pentaho
    2014-09-19 10:54:13.741::WARN: Failed startup of context org.mortbay.jetty.webapp.WebAppContext@adc04c{/pentaho,plugins
    /spoon/agile-bi/platform/webapps/pentaho}
    java.io.FileNotFoundException: plugins/spoon/agile-bi/platform/webapps/pentaho
    at org.mortbay.jetty.webapp.WebAppContext.resolveWebApp(WebAppContext.java:965)
    at org.mortbay.jetty.webapp.WebAppContext.getWebInf(WebAppContext.java:800)
    at org.mortbay.jetty.webapp.WebInfConfiguration.configureClassLoader(WebInfConfiguration.java:62)
    at org.mortbay.jetty.webapp.WebAppContext.doStart(WebAppContext.java:457)
    at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
    at org.mortbay.jetty.handler.HandlerCollection.doStart(HandlerCollection.java:152)
    at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
    at org.mortbay.jetty.handler.HandlerWrapper.doStart(HandlerWrapper.java:130)
    at org.mortbay.jetty.Server.doStart(Server.java:224)
    at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:50)
    at org.pentaho.agilebi.platform.JettyServer.startServer(JettyServer.java:77)
    at org.pentaho.di.core.lifecycle.pdi.AgileBILifecycleListener$1.run(AgileBILifecycleListener.java:106)
    at java.lang.Thread.run(Thread.java:745)
    2014-09-19 10:54:13.808::INFO: Started SocketConnector@localhost:10000


    what should I do to resolve this error ?
    thanks for any answer .

  4. #4
    Join Date
    Oct 2014
    Posts
    1

    Default

    Hi Claudio,

    had the same problem. I was able to make it work by creating a dir junction between /data-integration/plugins/spoon and /data-integration/plugins (use mklink /J in a cmd shell running as Administrator). I don't know if this is the best solution, but at least it worked for me. Now I can use the modeler that before was trowing a nullPointer Exception. I also had to create the esapi dir and add esapi.properties and validation.properties from google (there are posts in the forum about this). I noticed that Spoon is much slower at startup after the the jetty error was fixed.

    hope this helps
    Cheers

  5. #5
    Join Date
    Jul 2014
    Posts
    4

    Default

    Hi Claudio,

    Can you elaborate on how to create the junction?

    1. I dont see the path /data-integration/plugins/spoon
    2. Would you be able to elaborate the steps you did to create the esapi dir and how you added the esapi.properties and validation.properties file.

    REgards,

    Nathan

  6. #6
    Join Date
    Jul 2014
    Posts
    4

    Default

    Hi All,

    I was able to resolve the issue by simply doing the following steps:

    1. Add the missing slf4j-api-1.7.3.jar file to the /lib folder
    2. Create the folder /spoon inside the /data-integration/plugins/
    3. Unzip the pmv* file to the path ./data-integration/plugins/spoon

    Hope this helps

    Thanks & Regards,

    Nathan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.