Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: pdi 5.1 and agile bi

  1. #1

    Default pdi 5.1 and agile bi

    I have tried to install on pdi 5.1 ( dowloaded from sourceforge => the agile bi plugin ( downloaded from sourceforge => ) .
    My os is windows 7 32 bit with java version 1.7.0_65 .
    I have unzipped the and copied the agile-bi dir in data-integration\plugins .
    At this point i have started spoon but it does not start anymore ( it only visualize the splash screen ) .
    If i remove the dir agile-bi spoon work well .
    I have run spoon also from the dos command line but i can't see any error .
    Have i done something wrong ?
    Thanks for any answer ?

  2. #2
    Join Date
    Apr 2008


    I think that in PDI 5.1 you can install the Agile plug in using the Marketplace.
    Have you tried it?
    -- Mick --

  3. #3


    i have checked the marketplace òist of plugins but i have not find the agile plugin in it .

    anyway i have solved the problem copying the lib slf4j-api-1.7.3.jar and slf4j-log4j12-1.7.3.jar in /data-integration/plugins/agile-bi/lib/ .

    To display the error on the console i have run spoon with the command SpoonDebug.bat .

    Spoon now is working and however i get the error that follow :

    Launching Spoon: "E:\Programs\pentaho\pdi\bin\5.1.0\data-integration\spoon.bat" /levelebug
    Console output gets redirected to "E:\Programs\pentaho\pdi\bin\5.1.0\data-integration\SpoonDebug.txt"
    2014-09-19 10:54:13.553::INFO: Logging to STDERR via org.mortbay.log.StdErrLog
    2014-09-19 10:54:13.578::INFO: jetty-6.1.21
    2014-09-19 10:54:13.730::WARN: Web application not found plugins/spoon/agile-bi/platform/webapps/pentaho
    2014-09-19 10:54:13.741::WARN: Failed startup of context org.mortbay.jetty.webapp.WebAppContext@adc04c{/pentaho,plugins
    /spoon/agile-bi/platform/webapps/pentaho} plugins/spoon/agile-bi/platform/webapps/pentaho
    at org.mortbay.jetty.webapp.WebAppContext.resolveWebApp(
    at org.mortbay.jetty.webapp.WebAppContext.getWebInf(
    at org.mortbay.jetty.webapp.WebInfConfiguration.configureClassLoader(
    at org.mortbay.jetty.webapp.WebAppContext.doStart(
    at org.mortbay.component.AbstractLifeCycle.start(
    at org.mortbay.jetty.handler.HandlerCollection.doStart(
    at org.mortbay.component.AbstractLifeCycle.start(
    at org.mortbay.jetty.handler.HandlerWrapper.doStart(
    at org.mortbay.jetty.Server.doStart(
    at org.mortbay.component.AbstractLifeCycle.start(
    at org.pentaho.agilebi.platform.JettyServer.startServer(
    at org.pentaho.di.core.lifecycle.pdi.AgileBILifecycleListener$
    2014-09-19 10:54:13.808::INFO: Started SocketConnector@localhost:10000

    what should I do to resolve this error ?
    thanks for any answer .

  4. #4
    Join Date
    Oct 2014


    Hi Claudio,

    had the same problem. I was able to make it work by creating a dir junction between /data-integration/plugins/spoon and /data-integration/plugins (use mklink /J in a cmd shell running as Administrator). I don't know if this is the best solution, but at least it worked for me. Now I can use the modeler that before was trowing a nullPointer Exception. I also had to create the esapi dir and add and from google (there are posts in the forum about this). I noticed that Spoon is much slower at startup after the the jetty error was fixed.

    hope this helps

  5. #5
    Join Date
    Jul 2014


    Hi Claudio,

    Can you elaborate on how to create the junction?

    1. I dont see the path /data-integration/plugins/spoon
    2. Would you be able to elaborate the steps you did to create the esapi dir and how you added the and file.



  6. #6
    Join Date
    Jul 2014


    Hi All,

    I was able to resolve the issue by simply doing the following steps:

    1. Add the missing slf4j-api-1.7.3.jar file to the /lib folder
    2. Create the folder /spoon inside the /data-integration/plugins/
    3. Unzip the pmv* file to the path ./data-integration/plugins/spoon

    Hope this helps

    Thanks & Regards,


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.