Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: pentaho data source not showing fields

  1. #1
    Join Date
    Sep 2017

    Question pentaho data source not showing fields

    I have a pentaho report that was working, using pentaho datasource. I had to re-do the PDI transformation so I was re-doing my report.

    (That's another thing, why can't I just change a datasource for a subreport? I end up re-doing them - quite a bit)

    Sorry. Continuing...

    Now I cannot get the fields to show for a query. I have a transformation with about 5 db queries on it. They're fine. When I use the .ktr, I can "preview" and see all the correct data. However, when I try and use the query, I can't "select" it and have the fields show. I've tried a new report, which has worked for this in the past, but nothing is working. Here's what it looks like:

    Name:  Screen Shot 2017-10-31 at 3.27.23 PM.png
Views: 1015
Size:  11.4 KB

    You'll notice that the folder icon has a horizontal line through it. That's all that happens when you select that query. Trying to use it when you create a sub report, same thing.

    I'm using PRD 7.1 and PDI 7.1 on a mac.

    Thank you kindly for any guidance.

  2. #2
    Join Date
    Nov 2017


    hai, you need to check the connection database first

  3. #3
    Join Date
    Sep 2017



    The database connection is doing fine. The PDI steps show the appropriate data for each query. Also, in the datasource query dialog, using "preview" the data shows up perfectly. The problem is that the fields don't show up to be used in the report.

    Thank you,

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.