Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Using Map Component in marker mode with City and Country data

  1. #1
    Join Date
    Jun 2014
    Posts
    13

    Default Using Map Component in marker mode with City and Country data

    Hello,

    I have a following problem with map component:
    - I use map component in markers mode with data columns "City, Country, Description" on Pentaho 5.2
    - Is Country considered when evaluating City name to position (longitude, latitude) on a map? It doesn't seems.

    The situation can be established by editing CDE sample:
    - Public > plugin-samples > CDE > CDE Reference > Map Component Full Test > Datasources > ForMapWithGeo > Query
    - After renaming city "Frankfurt" to "Dresden" in query code it doesn't take country into account and shows Dresden in the US, Ohio instead of in Germany.

    Any idea? Missing functionality? Or country definition cannot be used along with city?

    Thanks for any comment,
    Martin
    Last edited by mzahrada; 01-06-2015 at 04:59 AM.

  2. #2
    Join Date
    Jun 2014
    Posts
    13

    Default

    I found HTTP GET which is called to obtain longitude and latitude - it uses only "city" as a parameter:
    "http://nominatim.openstreetmap.org/search?format=json&limit=1&city=Dresden"

    How to extend a map component code by adding Country parameter so that this would be called instead:
    "http://nominatim.openstreetmap.org/search?format=json&limit=1&city=Dresden&country=Germany"

    Which file do I need to edit?

    Martin

  3. #3
    Join Date
    Jan 2014
    Posts
    189

    Default

    Hello Martin,

    I cannot reproduce this. Replacing "Frankfurt" with "Dresden" in the ForMapWithGeo triggers the query containing the "country=Germany" field and consequently yields the correct answer. Perhaps it's a matter of upgrading CDE and CDF to the latest stable version (I'm running 14.12.10.1)
    Cheers,
    Carlos

  4. #4
    Join Date
    Jun 2014
    Posts
    13

    Default

    Hello Carlos,

    I run Pentaho 5.2 with CDF, CDE, etc. of version 5.2.0.0-209 (branch 5.2). Marketplace says: "Up to Date". I will switch to last version 14.12.10.1 from STABLE branch and let you know.

    Thanks for help,
    Martin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.