Hitachi Vantara Pentaho Community Forums
Results 1 to 7 of 7

Thread: Is MSSQL JDBC driver supported?

  1. #1

    Default Is MSSQL JDBC driver supported?


    I have issues with Kettle 520 using MSSQL JDBC driver (sqljdbc41.jar) - see image.

    Name:  jdbc_error.jpg
Views: 647
Size:  29.1 KB

    Strange is that during connection test everything is fine, but during the execution Table Input step failed with error "The property integratedSecurity does not contain a valid boolean value".

    With jTDS driver there are no such issues.

    Any ideas if it is a bug or "by design"? Is it better to use jTDS or native msft jdbc driver?

  2. #2
    Join Date
    Nov 1999


    Strange thing. Check the options tab, is there an integratedSecurity option specified?
    The Help button on that tab should point you to the list of valid JDBC options for the driver.

  3. #3


    Hi Matt,
    I haven't changed any options - it is empty.
    Name:  kettle_options.jpg
Views: 597
Size:  16.0 KB
    I got these JDBC drivers at
    Used version 41 (sqljdbc41.jar) or older 4 (sqljdbc4.jar) - all produced the same error.
    Java version, Windows 8 / Server 2012 R2 environment.
    Transformation is attached, but there are the same issue with other transformations with just Table Input (simple select) and Dummy Output. Should I open jira ticket for that?

    Attached Files Attached Files

  4. #4
    Join Date
    Nov 1999


    Your expectations of me are too high unfortunately.
    Call Pentaho support of Google around for the error first. You'll notice the error is not Kettle specific.

  5. #5
    Join Date
    Nov 2013


    The property integratedSecurity does not contain a valid boolean value. Only the values true or false can be used.
    ... can occur if:
    - The semicolon ( after the value assigned to the integratedSecurity property was omitted.

  6. #6


    I figured out that issue is happenning only when my repository is in MSSQL Server. No issues if I run the same transformation exported to xml repository.
    I know MSSQL Server is not supported for repository, but so far that is the only issue and only with MSSQL JDBC driver. No issues with jTDS driver.

    Any ideas why MSSQL is not supported for repository?

  7. #7
    Join Date
    Jun 2009


    Hi all,

    this is a bug that has been persisting since 5.2. i submitted it to and i think there has been a fix reported for 5.4.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.