Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Upload Files to FTP step

  1. #1
    Join Date
    Apr 2015
    Posts
    2

    Default Upload Files to FTP step

    Hello, i have a problem connecting to the FTP server when using the "Upload files to FTPS step":
    i have an ssl explicit connection type.
    i put on the server name : ftpes://xxxxxxxxxx.com
    port: 21
    username: yyyyy@xxxxxxxxxx.com
    Connection type : TLS
    when i click on test connection the first time the error message shows : Error Trying to connect to host! Exception: Error connecting to host [ftpes://xxxxxxxxxx.com:21]! FtpIOException--> Return Value: 530 Description : Error connection to : ftpes://xxxxxxxxxx.com:21

    When i click on test button at the second time it shows connection OK,
    But when i execute my job the same error message show up.

    Anyone idea please.

    Thnaks in advance

  2. #2

    Default

    Hello,

    +1 for this thread, I've got the exact same bug (connexion test okay when setting up parameters, but fails when executing)

    Thank you for helping

  3. #3
    Join Date
    Sep 2013
    Posts
    235

    Default

    The trick of test ok is that it is do check only for first time. After you change something in settings - this still be ok in any case. Close and reopen job entry can help - old issue - seems still not be fixed - may be in 6.0
    Do not put server name with 'ftpes' - just use DNS server name.
    And one thing - if it could be valuable for your case - I am not 100% ftpes/ftps job entries can guarantee mitm protection. If it is possible may consider sftp step where is ftp is inside ssh.
    Anyway - hope it will help.

  4. #4
    Join Date
    Apr 2015
    Posts
    2

    Default

    The problem is solved i had i problem with the certificate, once i added it to the keystore , it works perfectly.

    The test button works only for the first time, if you want to retest you have to close the step and re-open it. it's a pentaho bug.

    Thanks,

  5. #5
    Join Date
    Feb 2015
    Posts
    1

    Default

    Hi Zaineb,

    I am facing same to issue to connect to FTPS server and once I click on test connect its throwing error and in second attempt its get connected. But I run at Job level its not connecting.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.