Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: ERROR while trying to use jndi connection

  1. #1
    Join Date
    Dec 2014
    Posts
    17

    Default ERROR while trying to use jndi connection

    Still i am getting error
    I am getting the below error
    ConnectionServiceImpl.Error_0009 Connection to database[BI] failed
    I am using Pentaho BI server community edition 5.2.0 version and i am trying to use JNDI connection where i am getting the error.
    For JDBC connection it worked fine
    I have defined the JNDI credentials inside the
    "biserver-ce-5.2.0.0-209\biserver-ce\pentaho-solutions\system\simple-jndi\jdbc.properties"
    Please help me on this


    I have followed the following steps


    • Stop the Tomcat and BA servers.
    • Edit the /tomcat/webapps/pentaho/WEB-INF/web.xml file.
    • At the end of the <web-app> element, in the same part of the file where you see <!-- insert additional resource-refs -->, add this XML snippet.<resource-ref>
      <description>BI</description>
      <res-ref-name>jdbc/BI</res-ref-name>
      <res-type>javax.sql.DataSource</res-type>
      <res-auth>Container</res-auth>
      </resource-ref>Change the description and res-ref-name nodes, as well as any others that apply to your situation and fit your database. You may need to consulthttp://tomcat.apache.org/tomcat-6.0-...les-howto.htmlto see if there are other things to consider.
    • Save and close the web.xml file.
    • Edit the /tomcat/conf/context.xml with a text editor. Alternatively, you can modify the/tomcat/webapps/pentaho/META-INF/context.xml file if you want this data connection to be available only to the BA Server. Adding JNDI connections to the context.xml makes them available to all of the webapps deployed to this Tomcat instance.
    • Anywhere inside of the <Context> element, add this XML snippet. Then save and close the context.xml file.<Resource name="jdbc/BI"
      auth="Container" type="javax.sql.DataSource"
      factory="org.apache.commons.dbcp.BasicDataSourceFactory"
      maxActive="20"
      maxIdle="5"
      maxWait="10000"
      username="dbuser"
      password="password"
      driverClassName="org.postgresql.Driver"
      url="jdbcostgresql://localhost:5432/wisdom2412"
      /> This example shows a simple PostgreSQL configuration. Replace the Resource name, username, password,driverClassName, and url parameters, or any relevant connection settings, to match your database connection information and the details you supplied in the web.xml file earlier.
    • Delete the pentaho.xml filed located in the /tomcat/conf/catalina/directory. The pentaho.xml is a cached copy of the context.xml file you modified. Since the cache is not usually configured to update frequently, you have to delete the pentaho.xml file and let Tomcat recreate it when it starts up.
    • Start the Tomcat and BA Server.




    PLEASE HELP ME ON THIS>>>>>>>>>>>>>>>>>>>>>

  2. #2

    Default

    Pentaho have a issue in JNDI for version 5.2. You should update Pentaho to >= 5.3 CE.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.