Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Environment for debugging Kettle

  1. #1

    Default Environment for debugging Kettle

    Hi,
    I'm new to developing in Eclipse so please be lenient with me.

    For the developing of a custom Kettle-Step I need to set up an Eclipse environment where I can develop and debug a new transformation step.

    I did the following:
    • downloaded the source of the Branch 5.4.0.3 from git
    • ran "ant clean-all resolve create-dot-classpath" as described in the README.txt and it finished with BUILD SUCCESSFUL

    Now I would like to compile and run/debug in Eclipse:
    So I opened the Project by importing the "Existing Projects into Workspace" with checked option "Search for nested projects" and got all the Kettle-Core,-DB Dialog,-Engine,-UI and PlugIn-Projects and the 'pentaho-kettle'-project. (All projects on the same level!)
    As the README.txt says there should be a launch configuration for Run and Debug... but there isn't.

    To build the whole project from Eclipse I tried "Build Project" on the 'pentaho-kettle'-project and got tons of errors.
    So I tried to run the build.xml as Ant-Task (right click on build.xml ->'run as' ->'Ant Build') got several warnings but also a BUILD SUCCESSFUL!

    But I have still no launch configuration and when I try to run the Launch-File (pentaho-kettle-5.4.0.3.launch) it comes up with "Launch configuration pentaho-kettle-5.4.0.3 references non-existing project pentaho-kettle-5.4.0.3."
    I guess I messed something up with the project import in Eclipse. Can anybody help me?

    My Environment looks like this:
    • Eclipse Luna (4.4.2)
      (with the Apache Ivy PlugIns(Ivy Ant Tasks, IvyDE, IvyDE ResolveVisualizer) and some SVN-Plugins)
      Compiler compliance level is set to 1.7.
    • JDK 7u80
    • ANT 1.9.6

    Thanks in advance!

  2. #2

    Default

    Any suggestions?
    Is this the right forum for this question?
    Do you need more details?

    Please give me some hints!

  3. #3

    Default Environment for developing a custom Kettle Step

    Hi,
    for the development of a custom Kettle-Step I need to set up an Eclipse environment where I can develop and debug a new transformation step.

    I did the following:
    • Downloaded the source of the Branch 5.4.0.3 from git (https://github.com/pentaho/pentaho-kettle)
    • ran "ant clean-all resolve create-dot-classpath" as described in the README.txt and it finished with BUILD SUCCESSFUL


    Now I would like to compile and run/debug in Eclipse:
    So I opened the Project by importing the "Existing Projects into Workspace" with checked option "Search for nested projects" and got all the Kettle-Core,-DB Dialog,-Engine,-UI and PlugIn-Projects and the 'pentaho-kettle'-project. (All projects on the same level!)
    As the README.txt says there should be a launch configuration for Run and Debug... but there isn't.

    To build the whole project from Eclipse I tried "Build Project" on the 'pentaho-kettle'-project and got tons of errors.
    So I tried to run the build.xml as Ant-Task (right click on build.xml ->'run as' ->'Ant Build') got several warnings but also a BUILD SUCCESSFUL!

    But I have still no launch configuration and when I try to run the Launch-File (pentaho-kettle-5.4.0.3.launch) it comes up with "Launch configuration pentaho-kettle-5.4.0.3 references non-existing project pentaho-kettle-5.4.0.3."
    I guess I messed something up with the project import in Eclipse. Can anybody help me?

    My Environment looks like this:
    • Eclipse Luna (4.4.2)
      (with the Apache Ivy PlugIns(Ivy Ant Tasks, IvyDE, IvyDE ResolveVisualizer) and some SVN-Plugins)
    • Compiler compliance level is set to 1.7.
    • JDK 7u80
    • ANT 1.9.6


    Any ideas?
    Thanks in advance!

  4. #4
    Join Date
    Aug 2015
    Posts
    16

    Default

    Hello,

    Did you ever this this working? I'm new to this as well (and new to Eclipse / Java) and have been struggling with the steep learning curve. If you got this running correctly, I'd appreciate any help.

  5. #5

    Default

    Hi ryno1234,
    sorry, I've still got no clue!
    But I need to set this up in the next month so if I get a solution, workaround or something else I' let you know...

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.