Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: JNDI and integrating engine

  1. #1
    Join Date
    Oct 2015

    Default JNDI and integrating engine

    I am my wits end
    I have successfully integrated the reporting engine ( into a java app - works fine
    As soon a I change a report in the designer to be a JNDI that report fails to run in the app
    I have tried everything on the $HOME/.pentaho/simple_jndi/ file - all to no avail

    Using the JNDI config in the Designer report runs fine.
    All the reports in the app run fine provide they use the native mysql interfact either through localhost or HOSTNAME\

    Running the JNDI report in the java app produces 2 separate errors:
    1. Specified class org.pentaho.reporting.engine.classic.core.cache.EhCacheDataCache cannot be loaded [NOCLASSDEFERROR].

    To my knowledge all necessary jars are present, and This error does not occur unless trying to run a JNDI report

    2. The ubiquitous JNDI error org.pentaho.reporting.engine.classic.core.modules.misc.connections.DatasourceServiceException: Failed to access the JNDI system: Cannot find the requested datasource 'Multi' anywhere in the JNDI system.
    'Multi' is defined in the file

    Seems to me the is so other missing configuration file. The director simple-jndi has all the necessary component files and directories
    Searching through the code I can not find any obvious place where this is ever accessed...

    I have recently tried with the sdk sample examples, built the sample, loaded my prpt file into it, same error....

    Any guidance would be greatly appreciated


  2. #2
    Join Date
    Jul 2017


    i got same problem here, anyone could help?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.