Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Buiilding pentaho-kettle - build failure

  1. #1
    Join Date
    Oct 2015
    Posts
    12

    Default Buiilding pentaho-kettle - build failure

    Hi, I'm trying to build pentaho-kettle from Github.
    I've tried both master and the 6.0.0.0-R tag, both fail with this error:

    Code:
    maven-install-dependencies:
         [echo] Installing D:\sources\Pentaho\pentaho-kettle\core/dist/ivy-6.1-SNAPSHOT.xml ...
         [exec] [INFO] Scanning for projects...
         [exec] [INFO] ------------------------------------------------------------------------
         [exec] [INFO] BUILD FAILURE
         [exec] [INFO] ------------------------------------------------------------------------
         [exec] [INFO] Total time: 0.547 s
         [exec] [INFO] Finished at: 2015-10-20T16:19:42+02:00
         [exec] [INFO] Final Memory: 4M/122M
         [exec] [INFO] ------------------------------------------------------------------------
         [exec] [ERROR] The goal you specified requires a project to execute but there is no POM in this directory (D:\sources\Pentaho\pentaho-kettle\core). Please verify you invoked Maven from the correct directory. -> [Help 1]
         [exec] [ERROR]
         [exec] [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
         [exec] [ERROR] Re-run Maven using the -X switch to enable full debug logging.
         [exec] [ERROR]
         [exec] [ERROR] For more information about the errors and possible solutions, please read the following articles:
         [exec] [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MissingProjectException
    
    
    BUILD FAILED
    D:\sources\Pentaho\pentaho-kettle\build.xml:123: The following error occurred while executing this line:
    D:\sources\Pentaho\pentaho-kettle\build.xml:128: The following error occurred while executing this line:
    D:\sources\Pentaho\pentaho-kettle\core\build-res\subfloor.xml:1030: The following error occurred while executing this line:
    D:\sources\Pentaho\pentaho-kettle\core\build-res\subfloor.xml:1042: The following error occurred while executing this line:
    D:\sources\Pentaho\pentaho-kettle\core\build-res\subfloor.xml:1234: exec returned: 1
    There is indeed no pom.xml in core\ but it's generated in core\dist instead.

    Has anyone build pentaho-kettle from Github succesfully recently?
    Everything else on my workstation is setup correctly (Maven, Ant, Ivy etc).

  2. #2
    Join Date
    Oct 2015
    Posts
    12

    Default

    Is anyone able to build correctly?
    Or am I asking on the wrong forum?

  3. #3
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    You're asking in the right forum, but I haven't built from source.
    There might be some trick to it, but haven't never tried, I can't guide you. Most people will only comment when they can help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.