Hitachi Vantara Pentaho Community Forums
Results 1 to 1 of 1

Thread: BI Server 6 on Mac fails to start - java.net.BindException: Address already in use

  1. #1
    Join Date
    Oct 2015
    Posts
    2

    Default BI Server 6 on Mac fails to start - java.net.BindException: Address already in use

    I am getting an error that the address is already in use.

    Code:
    SEVERE [main] org.apache.coyote.AbstractProtocol.init Failed to initialize end point associated with ProtocolHandler ["http-nio-8080"] java.net.BindException: Address already in use
            at sun.nio.ch.Net.bind0(Native Method)
            at sun.nio.ch.Net.bind(Net.java:444)
            at sun.nio.ch.Net.bind(Net.java:436)
            at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:214)
            at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:74)
            at org.apache.tomcat.util.net.NioEndpoint.bind(NioEndpoint.java:339)
            at org.apache.tomcat.util.net.AbstractEndpoint.init(AbstractEndpoint.java:737)
            at org.apache.coyote.AbstractProtocol.init(AbstractProtocol.java:457)
            at org.apache.coyote.http11.AbstractHttp11JsseProtocol.init(AbstractHttp11JsseProtocol.java:120)
            at org.apache.catalina.connector.Connector.initInternal(Connector.java:960)
            at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
            at org.apache.catalina.core.StandardService.initInternal(StandardService.java:567)
            at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
            at org.apache.catalina.core.StandardServer.initInternal(StandardServer.java:851)
            at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
            at org.apache.catalina.startup.Catalina.load(Catalina.java:576)
            at org.apache.catalina.startup.Catalina.load(Catalina.java:599)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
            at java.lang.reflect.Method.invoke(Method.java:606)
            at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:310)
            at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:484)
    I have checked there is no other service running on port 8080 on my machine. I stopped the pentaho suite and checked telnet to 8080. No service listening. Also checked the output of netstat & lsof.

    On hitting localhost:8080 I get a 404 error when pentaho is running.

    I am on Mac, java 7.
    Last edited by rishabhdua; 10-26-2015 at 05:17 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.