Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Linux: Unsupported major.minor version 51.0

  1. #1
    Join Date
    Nov 2015
    Posts
    2

    Default Linux: Unsupported major.minor version 51.0

    Hello everyone,

    We've been using an older version of PDI on a CentOS server to execute jobs and the new version 5.5 + version 6 had some useful plugins so we upgraded.
    Everything was going fine, until I attempted to upgrade the server's version on PDI.

    After uploading and replacing the contents of
    /app/pentaho/design-tools/data-integration
    with the new version we got this message.


    Exception in thread "main" java.lang.UnsupportedClassVersionError: org/pentaho/commons/launcher/Launcher : Unsupported major.minor version 51.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
    at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
    Could not find the main class: org.pentaho.commons.launcher.Launcher. Program will exit.

    My researching kept pointing to java compatibility so We tried upgrading the java on the box from


    [dmi@sc-dmipdi1 ~]$ java -version
    java version "1.7.0_45"
    OpenJDK Runtime Environment (rhel-2.4.3.3.el6-x86_64 u45-b15)
    OpenJDK 64-Bit Server VM (build 24.45-b08, mixed mode)
    to official oracle java 1.7

    [dmi@sc-dmipdi1 ~]$ java -version
    java version "1.7.0_79"
    Java(TM) SE Runtime Environment (build 1.7.0_79-b15)
    Java HotSpot(TM) 64-Bit Server VM (build 24.79-b02, mixed mode)
    and then out of desperation even tried to downgrade it back to 1.6

    [dmi@sc-dmipdi1 ~]$ java -version
    java version "1.6.0_45"
    Java(TM) SE Runtime Environment (build 1.6.0_45-b06)
    Java HotSpot(TM) 64-Bit Server VM (build 20.45-b01, mixed mode)


    Whiel I've worked indirectly with PDI for 2 years I'm very new to this server side setup.
    I wondered if there was a settings file that the old PDI had, installed before my time. So I compared as many as I could but didnt see anything relevant to our setup that needed to transfer.

    we did save the old PDI at @
    /app/pentaho/design-tools/data-integration-old/
    and the kitchen.sh still works there with older scripts.

    I am unsure of where to turn next, so was hoping someone here may have an answer or could point me int he right direction.

    Please let me know if any additional information from my side would be helpful.

    Thank you for your time and attention

    Edit 1:
    Note I downloaded the PDI instance for version 6.0 directly from: http://community.pentaho.com/projects/data-integration/
    Last edited by dpiestrak; 11-23-2015 at 01:26 PM.

  2. #2
    Join Date
    Aug 2011
    Posts
    360

    Default

    Some clues:
    - define explicitly the environnment variables JAVA_HOME and PENTAHO_JAVA_HOME to point
    to your java installation, which should be at least java 7 i think (up to java 8 for oentaho 6)
    - define also the variable KETTLE_HOME to point in an other place than your old PDI installation.
    -> usualy the kettle home is in the user home dir, where there should be a .kettle dir.

    Maybe you should too remove the old .pentaho dir (do s backup!) In the same user home dir.

    I thibk there are old stuff feom previous installation in these directories.

    Good luck!

  3. #3
    Join Date
    Dec 2009
    Posts
    332

    Default

    We are running pdi 6.0.0.0-353 on linux with java version 1.7.0_80 without issues.

    In the past we have had issues where the PDI start up script (kitchen.sh/spoon.sh) chose an unexpected java version. This might be the cause of your issues. To detect these issues, we added the following line to spoon.sh to output which version of java it was actually running. This goes in just prior to the line where it starts the launcher:
    "$PENTAHO_JAVA" -version

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.