Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Failed on initializing step using SQL_CONNECT on Postgres

  1. #1
    Join Date
    Oct 2014
    Posts
    26

    Default Failed on initializing step using SQL_CONNECT on Postgres

    I have configured a connection of a transformation on Postgres to execute SET SEARCH_PATH right after connecting (SQL_CONNECT).
    Some steps are initialized properly:
    2015/12/01 21:44:54 - STAGE_1GRAU - New database connection defined
    2015/12/01 21:44:54 - STAGE_1GRAU - launch DDL statement:
    2015/12/01 21:44:54 - STAGE_1GRAU - SET SEARCH_PATH=pje_eg,public
    2015/12/01 21:44:54 - STAGE_1GRAU - 1 statement executed
    2015/12/01 21:44:54 - STAGE_1GRAU - Executed connect time SQL statements:
    2015/12/01 21:44:54 - STAGE_1GRAU - SET SEARCH_PATH=pje_eg,public;

    However, some step failed on initializing:
    2015/12/01 21:44:56 - Invoca carga.0 - ERROR (version 5.4.0.1-130, build 1 from 2015-06-14_12-34-55 by buildguy) : Ocorreu um erro, o processamento ser? interrompido:
    2015/12/01 21:44:56 - Invoca carga.0 - Error occurred while trying to connect to the database
    2015/12/01 21:44:56 - Invoca carga.0 -
    2015/12/01 21:44:56 - Invoca carga.0 - Couldn't execute SQL: SET SEARCH_PATH=pje_eg,public
    2015/12/01 21:44:56 - Invoca carga.0 -
    2015/12/01 21:44:56 - Invoca carga.0 - An I/O error occurred while sending to the backend.
    2015/12/01 21:44:56 - Invoca carga.0 - ERROR (version 5.4.0.1-130, build 1 from 2015-06-14_12-34-55 by buildguy) : Erro inicializando step [Invoca carga]

    I am using pooling on Postgres and the parameters:
    <attribute><code>MAXIMUM_POOL_SIZE</code><attribute>30</attribute></attribute>
    <attribute><code>POOLING_maxActive</code><attribute>20</attribute></attribute>
    <attribute><code>POOLING_maxIdle</code><attribute>10</attribute></attribute>
    <attribute><code>POOLING_testOnBorrow</code><attribute>true</attribute></attribute>
    <attribute><code>POOLING_testOnReturn</code><attribute>true</attribute></attribute>
    <attribute><code>POOLING_testWhileIdle</code><attribute>true</attribute></attribute>
    <attribute><code>POOLING_validationQuery</code><attribute>select 1</attribute></attribute>

    Anyone knows to fix the problem?

    Best,

    Orair.

  2. #2
    Join Date
    Jul 2009
    Posts
    476

    Default

    I would avoid this issue by setting the search path for the database user account:

    Code:
    ALTER USER <user> SET search_path=pje_eg,public;
    Then all of your connections will get the right search_path by default.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.