Hitachi Vantara Pentaho Community Forums
Results 1 to 9 of 9

Thread: PDI 6 does not start

  1. #1

    Default PDI 6 does not start

    Hi everyone,

    I am having trouble to run PDI 6 in my computer. This is what I did.

    1. I have downloaded "pdi-ce-6.0.1.0-386" and tried to run it in my laptop. Current OS is Windows 8.1 Pro 64bits (x64).
    2. I have downloaded and installed the latest version of Java (1.8.0_66-b18). In my computer Setting it says this is a 32bits version (not sure if this is correct)
    3. I tried several times to run spoon bit it did not work
    4. I updated the PATH adding the variable %JAVA_HOME%\bin; to the current value. I added a new system variable called CLASSPATH with value %JAVA_HOME%\lib and another one called JAVA_HOME with value C:\Program Files (x86)\Java\jre1.8.0_665. I tried to run spoon and it did not work
    6. I have downloaded PDI 5.0.1 and it runs

    I cannot understand what I am doing wrong. I could be PDI 6 requires specific settings to be run. Can anyone help me?

    Thank you

  2. #2
    Join Date
    Nov 2009
    Posts
    688

    Default

    Because you are running with java 32 bits you have to edit the spoon.bat. Look for if: "%PENTAHO_DI_JAVA_OPTIONS%"=="" set PENTAHO_DI_JAVA_OPTIONS="-Xms1024m" "-Xmx2048m" "-XX:MaxPermSize=256m"
    and change that to
    "%PENTAHO_DI_JAVA_OPTIONS%"=="" set PENTAHO_DI_JAVA_OPTIONS="-Xms1024m" "-Xmx1024m" "-XX:MaxPermSize=256m"
    java 32 bits cannot handle Xmx2048m

  3. #3

    Default

    Thank you very much. Now it works. I have a question: Can I install Java 64bits in my computer. I have tried reinstalling the current version of Java but it seems to keep the 32bits version

  4. #4
    Join Date
    Nov 2009
    Posts
    688

    Default

    When you have a 64 bits machine you should be able to install java 64 bits. (it is possible to have both java 32 and 64 bits). The 64 bits version of java is by default installed C:\Program Files
    For download java see http://www.oracle.com/technetwork/ja...s-2133155.html

  5. #5

    Default

    Johanhammink,

    Thank you your answer. I have upgraded my java version. Now I have the 64bits version installed in my computer. This is where I get in the prompt:

    java version "1.8.0_66"
    Java(TM) SE Runtime Environment (build 1.8.0_66-b18)
    Java HotSpot(TM) 64-Bit Server VM (build 25.66-b18, mixed mode)


    I have edited spoon.bat and replaced PENTAHO_DI_JAVA_OPTIONS="-Xms1024m" "-Xmx1024m" forPENTAHO_DI_JAVA_OPTIONS="-Xms1024m" "-Xmx2048m". (here I am assuming that if I have the 64bits version of Java installed in my computer, I should be able to run spoon with the the option "-Xmx2048m")


    I have tried to run spoon this way but I have the same problem again: it does not run. This is what I get in the prompt:


    C:\data-integration>spoon
    DEBUG: Using JAVA_HOME
    DEBUG: _PENTAHO_JAVA_HOME=C:\Program Files (x86)\Java\jre1.8.0_66
    DEBUG: _PENTAHO_JAVA=C:\Program Files (x86)\Java\jre1.8.0_66\bin\javaw.exe

    C:\data-integration>start "Spoon" "C:\Program Files (x86)\Java\jre1.8.0_66\bin\j
    avaw.exe" "-Xms1024m" "-Xmx2048m" "-XX:MaxPermSize=256m" "-Dhttps.protocols=TLS
    v1,TLSv1.1,TLSv1.2" "-Djava.library.path=libswt\win32" "-DKETTLE_HOME=" "-DKETTL
    E_REPOSITORY=" "-DKETTLE_USER=" "-DKETTLE_PASSWORD=" "-DKETTLE_PLUGIN_PACKAGES="
    "-DKETTLE_LOG_SIZE_LIMIT=" "-DKETTLE_JNDI_ROOT=" -jar launcher\pentaho-applicat
    ion-launcher-6.0.1.0-386.jar -lib ..\libswt\win32

    C:\data-integration>

    Any suggestion?

  6. #6
    Join Date
    Nov 2009
    Posts
    688

    Default

    C:\data-integration>spoon
    DEBUG: Using JAVA_HOME
    DEBUG: _PENTAHO_JAVA_HOME=C:\Program Files (x86)\Java\jre1.8.0_66
    DEBUG: _PENTAHO_JAVA=C:\Program Files (x86)\Java\jre1.8.0_66\bin\javaw.exe

    Any suggestion?[/QUOTE]

    You are still working with the JAVA 32 bits version. Make an Environment variable called "JAVA_HOME" that called to the 64 bits version of JAVA. Something like C:\Program Files\Java\jre1.8

  7. #7

    Default

    Thank you. Now it works.

  8. #8
    Join Date
    Jun 2014
    Posts
    4

    Default I have similar problem

    Quote Originally Posted by johanhammink View Post
    Because you are running with java 32 bits you have to edit the spoon.bat. Look for if: "%PENTAHO_DI_JAVA_OPTIONS%"=="" set PENTAHO_DI_JAVA_OPTIONS="-Xms1024m" "-Xmx2048m" "-XX:MaxPermSize=256m"
    and change that to
    "%PENTAHO_DI_JAVA_OPTIONS%"=="" set PENTAHO_DI_JAVA_OPTIONS="-Xms1024m" "-Xmx1024m" "-XX:MaxPermSize=256m"
    java 32 bits cannot handle Xmx2048m

    Hi, I have similar problem. After make the adjustments suggested above, Pentaho 6.0.1 starts and I see the start image with Pentaho version, but after that nothing happens. Any ideas? Thanks for help.

    I am setting this up on Windows server 2008, 64 bit, but it runs Java 7 update 72 32 bit.

    One suggestion I was able to find was to change "start javaw" to just "java" but I don't see that in Spoon file. Should I be changing
    "set PENTAHO_JAVA=javaw.exe" to "set PENTAHO_JAVA=java.exe"

    Thanks for your help.

  9. #9
    Join Date
    Jun 2014
    Posts
    4

    Default

    I Have figured my problem. I have unzipped PDI on Windows 7 and the files were copied to Windows Server 2008. Unzipping directly on Windows Server fixed my problem. Found the solution here: http://forums.pentaho.com/showthread...g-pdi-on-Win-7

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.