Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Composite partition key in Cassandra output

  1. #1

    Default Composite partition key in Cassandra output

    I am trying to take some data out of Oracle and into Cassandra using Pentaho DI (Version: 6.0). Everything works fine if i use a partition key with a single column.
    But I need to use a composite partition key:
    ((field1, field2, field3), field4)


    I have tried to enter this with brackets in the "Incoming fields to use as the key" field in the Write Options tab but that doesnt work. Tried some more options but to no avail. I also keep the "Use CQL version 3" option selected.
    Is this possible and if so how.

    Thanks

    Update:
    I also found the following issue which has been fixed in 5.0 GA -
    http://jira.pentaho.com/browse/PDI-9443

    It states: "New CQL 3 mode allows the user to specify a compound key where the partition element can be either a single field or a composite."

    So looks like I can do this but there is no help on how to define it. Also looking at the code it seems to be parsing only for commas so still dont know how to distinguish between the multiple fields of partition key and the clustering columns.
    Last edited by mkhar19@yahoo.com; 12-16-2015 at 02:38 AM.

  2. #2

    Default

    Figured it myself. There isn't proper documentation making this difficult.
    In any case the solution is to put the Create table query in the "CQL to execute before inserting first row" under the Schema Options tab.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.