Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: User Console Datasource Parameter Dropped after Publishing Mondrian Schema

  1. #1
    Join Date
    Dec 2015
    Posts
    18

    Question User Console Datasource Parameter Dropped after Publishing Mondrian Schema

    v5.4.0, EE

    I have implemented a DynamicSchemaProcessor that extends pentaho FilterDynamicSchemaProcessor, following the documentation here:
    https://help.pentaho.com/Documentati.../Multi-Tenancy

    To make use of the DSP, a 'DynamicSchemaProcessor' property has been added manually to Pentaho Analysis data source in the pentaho user console:
    pentaho user console > Manage Data Sources > Select data source > [gear-symbol] > add parameter

    This analysis datasource was also added through the user console.

    The DSP is working as expected, using my new class.

    However, if I re publish my mondrian schema, using schema workbench, the 'DynamicSchemaProcessor ' property in user console datasource gets dropped and I have to add it manually.
    The property is retained after logging off, restarting services etc. It only goes missing when the schema is published.

    Is there a properties file somewhere in 'pentaho-solutions' that I need to update to retain the parameter on the data source?

    Thanks
    Jason

  2. #2
    Join Date
    Dec 2015
    Posts
    18

    Default

    Turns out this is a known issue in 5.0.x

    A JIRA exists for the issue, although there is no progress on it:
    http://jira.pentaho.com/browse/BISERVER-11499

    The work around is to add the parameter back into the datasource manually, as I have been doing.

    Thanks
    Jason

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.