Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Pentaho Data Integration (Which Linux Flavor and Version is appropriate).

  1. #1
    Join Date
    Apr 2008
    Posts
    146

    Default Pentaho Data Integration (Which Linux Flavor and Version is appropriate).

    Is there a Linux flavor (Mint, SUSE, etc) that is better adapted to run Pentaho Data Integration with less fuss?

    background:
    Each time that I start out with new desktop based Linux, there are a few installation and configuration requirements beyond the Oracle JRE/JDK to get Pentaho Data Integration 5.x or 6.x up and going. Usually this involves one or two specific packages "xulrunner" at version 1.9.2, Webkit at 1.0 and sometimes fighting to get a version of the swt library that makes things work.

    The OS versions that I had success with after fighting with this are:
    CentOS 6.5 (versions 6.x to current) (forget, but seems like we had to disable cairo to get it working)
    Ubuntu 14.04 LTS. (Required swt snatched out of the eclipse install that is defaulted to the platform, xulrunner manual download, webkit 1.0)

    Thanks for any pointers.

  2. #2
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    Personally, I just did my design work on a Windows box, and then used Gentoo headless for the scheduled heavy lifting.
    Since I'm not trying to do anything graphical, it just worked.

    I've done the same thing on CentOS, SUSE, and a couple of other flavors as well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.