Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Connection Refused Error- HTTP Post

  1. #1
    Join Date
    Mar 2016
    Posts
    2

    Default Connection Refused Error- HTTP Post

    Hi,

    I am working on a transformation using HTTP Post. I get below error message. WHen I use the WSDL URL. The same usl outside of PDI, works fine.


    Connection refused: connect
    Can not result from [WSDL URL]
    at org.pentaho.di.trans.steps.httppost.HTTPPOST.callHTTPPOST(HTTPPOST.java:302)
    2016/03/10 15:09:13 - HTTP Post - .0 - at org.pentaho.di.trans.steps.httppost.HTTPPOST.processRow(HTTPPOST.java:425)
    2016/03/10 15:09:13 - HTTP Post - .0 - at org.pentaho.di.trans.step.RunThread.run(RunThread.java:62)
    2016/03/10 15:09:13 - HTTP Post - .0 - at java.lang.Thread.run(Unknown Source)
    2016/03/10 15:09:13 - HTTP Post - .0 - Caused by: java.net.ConnectException: Connection refused: connect

    Will appreciate inputs. Is there any settings like port # that is stopping the request to flow from pentaho?

    Thanks,
    Vaishali

  2. #2
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    Most common causes of this sort of thing are ACLs on routers.
    Connection refused is an error that occurs outside of PDI.

    When you say the "same url outside of PDI, works fine" do you mean that you tested it on the same machine?

    Note: WSDL (Web Service Definition Language) should probably use the Web Services Lookup step rather than the HTTP Post step.

  3. #3
    Join Date
    Mar 2016
    Posts
    2

    Default

    Quote Originally Posted by gutlez View Post
    Most common causes of this sort of thing are ACLs on routers.
    Connection refused is an error that occurs outside of PDI.

    When you say the "same url outside of PDI, works fine" do you mean that you tested it on the same machine?

    Note: WSDL (Web Service Definition Language) should probably use the Web Services Lookup step rather than the HTTP Post step.
    Thanks for your response gutlez. The url for wsdl works fine from any browser(IE/firefox) on same machine. i can view the complete elements. We did tried to use webservices lookup and was told that it didn't work. So we switched to generating SOAP message followed by HTTP post using WSDL. The connection refused error I suspect has to do with settings on PDI on my machine, One one thread I read, replacing localhost with exact IP address should work, OR it is a firewall Issue , Add exlplicit IP address in config.xml file. However I am not able to locate this file. Thoughts?

    Vaishali

  4. #4
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    Quote Originally Posted by Vaishali24 View Post
    replacing localhost with exact IP address should work, OR it is a firewall Issue , Add exlplicit IP address in config.xml file.
    Well you didn't give us much to work with, so I had to guess in the dark.

    If your WSDL is listening to localhost (only), and you put in your machine's IP address (or vice versa), then you'll get the connection refused message.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.