Hitachi Vantara Pentaho Community Forums
Results 1 to 9 of 9

Thread: date problem in kitchen report

  1. #1
    Join Date
    Feb 2016
    Posts
    12

    Default date problem in kitchen report

    I have one report being generated from a kjb.

    The problem is that in the prpt the query fetches data from a view, where I have 2 date fields. These dates come properly if I run query directly but if I run the report in kitchen in Unix environment, the dates comes as 2 days less that the actual date i.e. if the date in database table is 16-March-2016, in report I can see the date as 14-March-2016. This is the problem with both the dates.

    Need some pointers to debug and fix this. Please suggest.

    Thanks,
    Megha

  2. #2
    Join Date
    Apr 2008
    Posts
    1,771

    Default

    I would check the date of the server machine.
    -- Mick --

  3. #3
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    Pentaho tools will use the timezone of the "client" machine.
    If your client machine (the Unix machine) is in a significantly different timezone, then it may appear to have a two day difference in the dates.

  4. #4
    Join Date
    Feb 2016
    Posts
    12

    Default

    The client machine is also on the same timezone.

    And the dates are being picked from the database, I am using the system dates. These the the transaction posting dates from the DB being fetched in the report, which are appearing in the report as 2 days behind the date stored in the table for the records. Please suggest.

    Thanks,
    Megha

  5. #5
    Join Date
    Feb 2016
    Posts
    12

    Default

    No both the client and server are in same timezone. More over the date is from the records in tables.

  6. #6
    Join Date
    Feb 2016
    Posts
    12

    Default

    The dates where I am facing the issues in the report are the transaction posting dates from a table from DataBase. This is not the system date. These dates are appearing in the report as 2 days behind the date stored in the table for the records.
    Last edited by Megha_Punj; 03-16-2016 at 08:41 PM.

  7. #7
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    Quote Originally Posted by Megha_Punj View Post
    These the the transaction posting dates from the DB being fetched in the report, which are appearing in the report as 2 days behind the date stored in the table for the records.
    I can't understand what it is that you're trying to tell me here...

  8. #8
    Join Date
    Feb 2016
    Posts
    12

    Default

    Edited the comment. Please see and please tell me.

  9. #9
    Join Date
    Apr 2008
    Posts
    4,696

    Default

    I still don't understand what you are trying to say.

    If you are running a query in the DB and are seeing:

    ID| Date
    1 | 2016-03-17 00:00:00 UTC

    and are running the exact same query to populate a report and are seeing:
    ID| Date
    1 | 2016-03-15 00:00:00 UTC

    Then something really strange is going on that I really can't explain.
    However, if there is something else in the middle, then all sorts of things could be going on, and your attempts at abstracting it to explain it to us is making the issue really unclear.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.