Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Need help changing from 32-bit java to 64-bit when starting spoon.bat

  1. #1
    Join Date
    Mar 2016
    Posts
    3

    Default Need help changing from 32-bit java to 64-bit when starting spoon.bat

    I'm running Windows 8 64-bit, and recently downloaded PDI v6.0, and installed both 32-bit and 64-bit Java v1.8.0_73 respectively in Program Files (x86) and Program Files folders.

    When I started running spoon.bat, it defaulted to 32-bit java, and I updated spoon.bat file to change memory config from 2048 to 1024 in spoon.bat. Spoon.bat now spawns teh PDI console using the 32-bit java.

    However, I'd like to expand the memory available for jobs and am trying to get spoon.bat to find and run 64-bit java. I changed the environmental variable PENTAHO_JAVA_HOME to the 64-bit java directory, and when running spoon.bat from the command prompt, the DEBUG statement shows that it finds the 64-bit java folder, however the console does not open.

    Can anyone advise on how to get it running with 64-bit java? Thanks for your help!

  2. #2
    Join Date
    Aug 2015
    Posts
    313

    Default

    i am not sure why it is poiting to 32 bit java even though you have mentioned path with java 64 bit in environment variable.

    Do if possible from your end?

    1. open spoon.bat file and change if your spoon.bat file pointing to 32 bit version , you can manually change the java path in .bat file as well, there is no issue yet all.

    OR

    1. may be it silly mistake, i was faced so many times as well. once you have updated the java path in the environment variables then better to restart your machine and try it again.
    2. open spoon.bat file with RUN as Administrator

  3. #3
    Join Date
    Mar 2016
    Posts
    3

    Default

    Santhi - thank you for the help! I made the changes but it's still not working.

    I changed the environmental variable to point to 64-bit java folder, and then re-ran. It looks like it is finding the 64-bit java folder, but I noticed the spoon statement still pointed to the libswt/win32 - so in spoon.bat, I commented out that section to force it to point to libswt/win64.

    I rebooted and tried running that as admin from the command line, and it appears to show the correct spoon.bat statement in the command line, but no console window opens. I've enclosed a picture of the command line statement, and spoon.bat file.
    Attached Images Attached Images  
    Attached Files Attached Files

  4. #4
    Join Date
    Mar 2016
    Posts
    3

    Default Problem Solved

    Santhi,

    I've been playing around with it today, and finally went back, uninstalled all my instances of 32/64-bit java, then re-installed only the 64-bit java instance, and now it works, even without running as administrator. It must've been getting confused between java types or something, who knows?

    Thanks for your help!

    Matt

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.