Hitachi Vantara Pentaho Community Forums
Results 1 to 1 of 1

Thread: PDI 5.1 and Agile BI 5.1 Visualize HTTP 503 Problem

  1. #1

    Default PDI 5.1 and Agile BI 5.1 Visualize HTTP 503 Problem

    Hello

    I´am new in this forum and I have e problem with the Agile - BI Plugin. I want to test how it works. But I have a problem.

    My steps that I did.

    1. I did the following instrunctions like the Pentaho Wiki - Page http://wiki.pentaho.com/display/AGIL...I+on+Pentaho+5
    2. If I open a the Model view on the Table Output step, than i can drop the Measures and Dimensions
    3. Than I save the model and want to analyse. But after that i get a HTTP ERROR: 503. Look like the follwing picture.

    Name:  visualize_problem.jpg
Views: 30
Size:  8.9 KB

    ############################################
    Spoon - Debug - Mode

    C:\PENTAHO\data integration>"C:\Program Files\Java\jdk1.7.0_51\bin\java" "-Xmx512m" "-XX:MaxPermSize=256m" "-Djava.library.path=libswt\win64" "-DKETTLE_HOME=" "-DKETTLE_REPOSITORY=" "-DKETTLE_USER=" "-DKETTLE_PASSWORD=" "-DKETTLE_PLUGIN_PACKAGES=" "-DKETTLE_LOG_SIZE_LIMIT=" "-DKETTLE_JNDI_ROOT=" -jar launcher\pentaho-application-launcher-5.1.0.0-752.jar -lib ..\libswt\win64 /levelebug
    2016/03/21 20:39:46 - Spoon - Logging is at level : Debugging
    2016/03/21 20:39:48 - General - Starting agile-bi
    2016/03/21 20:39:48 - Version checker - OK
    2016/03/21 20:39:49 - class org.pentaho.agilebi.platform.JettyServer - WebServer.Log.CreateListener localhost:10000
    Attempting to load ESAPI.properties via file I/O.
    Attempting to load ESAPI.properties as resource file via file I/O.
    Not found in 'org.owasp.esapi.resources' directory or file not readable: C:\PENTAHO\data integration\ESAPI.properties
    Not found in SystemResource Directory/resourceDirectory: .esapi\ESAPI.properties
    Not found in 'user.home' (C:\Users\x) directory: C:\Users\x\esapi\ESAPI.properties
    Loading ESAPI.properties via file I/O failed. Exception was: java.io.FileNotFoundException
    Attempting to load ESAPI.properties via the classpath.
    SUCCESSFULLY LOADED ESAPI.properties via the CLASSPATH from '/ (root)' using current thread context class loader!
    SecurityConfiguration for Validator.ConfigurationFile not found in ESAPI.properties. Using default: validation.properties
    Attempting to load validation.properties via file I/O.
    Attempting to load validation.properties as resource file via file I/O.
    Not found in 'org.owasp.esapi.resources' directory or file not readable: C:\PENTAHO\data integration\validation.properties
    Not found in SystemResource Directory/resourceDirectory: .esapi\validation.properties
    Not found in 'user.home' (C:\Users\x) directory: C:\Users\x\esapi\validation.properties
    Loading validation.properties via file I/O failed.
    Attempting to load validation.properties via the classpath.
    validation.properties could not be loaded by any means. fail. Exception was: java.lang.IllegalArgumentException: Failed to load ESAPI.properties as a classloader resource.
    SecurityConfiguration for Logger.LogServerIP not either "true" or "false" in ESAPI.properties. Using default: true
    Attempting to load ESAPI.properties via file I/O.
    Attempting to load ESAPI.properties as resource file via file I/O.
    Not found in 'org.owasp.esapi.resources' directory or file not readable: C:\PENTAHO\data integration\ESAPI.properties
    Not found in SystemResource Directory/resourceDirectory: .esapi\ESAPI.properties
    Not found in 'user.home' (C:\Users\x) directory: C:\Users\x\esapi\ESAPI.properties
    Loading ESAPI.properties via file I/O failed. Exception was: java.io.FileNotFoundException
    Attempting to load ESAPI.properties via the classpath.
    SUCCESSFULLY LOADED ESAPI.properties via the CLASSPATH from '/ (root)' using current thread context class loader!
    SecurityConfiguration for Validator.ConfigurationFile not found in ESAPI.properties. Using default: validation.properties
    Attempting to load validation.properties via file I/O.
    Attempting to load validation.properties as resource file via file I/O.
    Not found in 'org.owasp.esapi.resources' directory or file not readable: C:\PENTAHO\data integration\validation.properties
    Not found in SystemResource Directory/resourceDirectory: .esapi\validation.properties
    Not found in 'user.home' (C:\Users\x) directory: C:\Users\x\esapi\validation.properties
    Loading validation.properties via file I/O failed.
    Attempting to load validation.properties via the classpath.
    validation.properties could not be loaded by any means. fail. Exception was: java.lang.IllegalArgumentException: Failed to load ESAPI.properties as a classloader resource.
    SecurityConfiguration for Logger.LogServerIP not either "true" or "false" in ESAPI.properties. Using default: true


    #############################################################################


    I have searched on the internet to find a solution for this problem, but I didnt find nothing that helps me.

    My System:
    Java Jdk 1.7.0_51
    Windows 10
    PDI 5.1.0.0 - ce
    Agile BI pmv-5.1.0.0-752

    I hope someone can help me, to find a solution.

    Sorry for my english.

    Greetings Oli
    ----------------------------------------------------------------------------------

    UPDATE

    I try it with Ubuntu too. I get the same issue.

    Console-Output

    Name:  visualize_ubuntu_failed.jpg
Views: 26
Size:  9.6 KB


    ----------------------------------------------------------------------------------
    Last edited by Oliver Schreiner; 03-23-2016 at 02:39 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.