Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: Not scaling for 4k dispalys

  1. #1
    Join Date
    Dec 2015
    Posts
    3

    Default Not scaling for 4k dispalys

    Hello,
    I have a new laptop with a 4k display which is amazing but a few apps don't scale properly to the resolution. All others are manageable but PDI scales in a way that the transformation is almost impossible to understand as the text and icons don't scale in the same way. Also things like the toolbar and popups don't scale correctly
    These are both on Windows 10

    4k display at 3840 x 2160 resolution
    Name:  High Res.jpg
Views: 385
Size:  22.9 KB
    Normal display at 1366 x 768 resolution
    Name:  Normal.jpg
Views: 380
Size:  30.7 KB
    Any ideas?
    Thanks

  2. #2
    Join Date
    May 2014
    Posts
    358

    Default

    You can try decreasing the font size and icon size and then zoom in using PgUp/PgDn keys. But I don't have a HiDPI screen so I don't know what it will do.

  3. #3
    Join Date
    Apr 2016
    Posts
    1

    Default

    Has anyone found a solution for this problem? Right now I have to use a separate monitor.

  4. #4
    Join Date
    May 2016
    Posts
    3

    Default

    Hi there,

    I am new to Pentaho community and coincidentally got the new windows 10 with 4K display.That turn out both good and bad for me. I just started learning Pentaho report designer and having the exact similar issue. Any help is greatly appreciated.

    Thanks in advance.

  5. #5

    Default

    Workaround available in http://jira.pentaho.com/browse/PDI-15394 (related to PDI), for PRD I'm still investigating myself.

  6. #6
    Join Date
    Oct 2006
    Posts
    18

    Default

    I have attempted to use the PDI-15394 workaround with Report Designer placing the Eclipse files (downloaded from latest Neon package) into the report-designer\lib folder and adding the parameter mentioned to the report-designer.bat launcher on Win10.
    Doesn't help. When I set '-Dswing.useSystemFontSettings=true', the fonts do get bigger but the "background" doesn't so the everything remains unworkable just the same.
    I am using a Dell 27" 5k monitor.
    Any other ideas? Or have I overlooked something I should not have?
    Without a solution...unfortunately...at this point it seems I'll have to find other report designer software.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.