Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Using Parameters on a server

  1. #1
    Join Date
    Feb 2016
    Posts
    27

    Default Using Parameters on a server

    Here is what I have:

    1. I have a newly created parameter. Let's called this parameter "example_1."
    2. This newly created parameter, example_1, does not exist on my machine locally, but only on the kettle properties file on the server level.
    3. Can I run a transformation, at the server level, using this newly created parameter?

    For example, I am using the "Get file names" step. In the "File or directory" area, I have this newly created parameter name, ${example_1}, but when I look at the results, nothing comes up when I try to run it at the server level.

    4.Am I doing something wrong?

  2. #2
    Join Date
    Jul 2009
    Posts
    476

    Default

    Are you providing the full path to the file, including the directory name?

  3. #3
    Join Date
    Feb 2016
    Posts
    27

    Default

    Yes

  4. #4
    Join Date
    Jul 2009
    Posts
    476

    Default

    Can you attach a copy of the transformation or job that is using this step? If you want, strip out everything except the Get File Names step and change the database connection parameters defined in the job/transformation if they contain username/password info.

    A couple of other ideas:
    (1) Are you sure that the kettle.properties file is in the right place on the server? On Linux/OSX, it's $HOME/.kettle/kettle.properties. On Windows, it's under the user's profile folder somewhere, I'm not exactly sure.
    (2) Does the user account running PDI on the server have sufficient permissions to see the file(s) that it is supposed to find?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.