Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: how to deal with "a date attribute" in weka?

  1. #1
    Join Date
    Apr 2014
    Posts
    8

    Default how to deal with "a date attribute" in weka?

    hi weka people

    i am new in weka ,, i have file in excel contain more than 1500 records , the file contain an attribute called date and written as"" 6/4/2014 for example" i saved as csv but when i opened the file with weka i found that weka considered the date attribute as nominal attribute because weka deal with date ittribute in form yyyy-mm-dd

    how can i solve this problem automatically please, i can not t rewrite more than 1500 records

    thanks alot

  2. #2
    Join Date
    Apr 2014
    Posts
    8

    Default help please

    29 views and no even 1 answer!!

    can any one help me please??

  3. #3
    Join Date
    Aug 2006
    Posts
    1,741

    Default

    On the open file dialog in the Explorer's Preprocess panel you will notice a checkbox called "Invoke options dialog". Check this and then you will get a second dialog with options for CSV import. Here you can specify which attributes should be considered nominal, date etc. and a format string for date parsing.

    Cheers,
    Mark.

  4. #4
    Join Date
    Apr 2014
    Posts
    8

    Default

    Quote Originally Posted by Mark View Post
    On the open file dialog in the Explorer's Preprocess panel you will notice a checkbox called "Invoke options dialog". Check this and then you will get a second dialog with options for CSV import. Here you can specify which attributes should be considered nominal, date etc. and a format string for date parsing.

    Cheers,
    Mark.
    Dear Mark

    thanks alot for your help , i use weka version 3.6 so i do not have a checkbox called "Invoke options dialog" but after i download new vesion i found it and it work,thanks alot

    best wishes

  5. #5
    Join Date
    Jun 2015
    Posts
    1

    Default

    Quote Originally Posted by Maha View Post
    Dear Mark

    thanks alot for your help , i use weka version 3.6 so i do not have a checkbox called "Invoke options dialog" but after i download new vesion i found it and it work,thanks alot

    best wishes
    What is the version you use now? I got the same problem. Please help

  6. #6
    Join Date
    May 2016
    Posts
    1

    Default

    This may be too late. But still in case any other people face the same question.
    I have a csv with date format dd.mm.yyyy. After loading it with Weka, this attribute is treated as nominal. You can edit the title and change it to the way you want. For example, I deleted all the values listed and set the date format accordingly, @attribute time DATE dd.mm.yyyy.
    Now after I load it to Weka Explorer, in the analyzing panel, it's showing the values with large numbers, which I have no idea about.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.