Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Pentaho JackrabbitR: ERROR [RepositoryImpl] Failed to initialize workspace 'default'

  1. #1

    Exclamation Pentaho JackrabbitR: ERROR [RepositoryImpl] Failed to initialize workspace 'default'


    I am using Pentaho biserver-ce 5, I have recently encountered an error described in the following post (I used google translate since the article is in Spanish):

    Basically the recommendation is to delete the index of the JCR repo and I did that but now have another error with regards to hibuser and pentaho_user not being found.

    Please see attachment (catalina.txt) for the stack trace. When trying to login the user console a Pentaho Initialization Exception occurs.

    How do I fix this?

    Thanks in advance.
    Attached Files Attached Files

  2. #2


    Ok now to update. I zeroed in on the hibuser error and it seems that my hibernate, quartz, and sampledata scripts had been deleted. Since these scripts are being executed when starting the biserver and the hypersonic database thus resulting to the previous error. I tried to replace these scripts and was now able to startup my server without errors but when I checked my server explorer (thru browse files in the user console), all the content is now gone/missing (all the published reports, dashboards, folders, users became default etc.)

    My question now is how do I recover the content published before (folders, reports, dashboards, users)? Is there still a way to do this?

  3. #3


    I was now able to fix my server. I made an error by moving my repository folder under .../pentaho-solutions/system/jacrabbit/repository to a backup folder (i did this because I thought deleting the index folder is not enough therefore I tried moving whole repository folder out) and not moving it back after fixing my hsql db. So basically all contents and users are stored in jackrabbit and after putting back the repository folder and restarting I was now able to see all the content again (folders, reports, dashboards, users). The only minor thing left i guess are the schedules which are stored in quartz. Since I copied the default script, the schedules were lost but I am okay with this as long as the contents have been restored.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.