Hitachi Vantara Pentaho Community Forums
Results 1 to 6 of 6

Thread: Missing plugins found while loading a Kettle transformation to pentaho report designe

  1. #1

    Default Missing plugins found while loading a Kettle transformation to pentaho report designe

    Hi everyone,


    I created a Kettle transformation which have a Apache Kafka Consumer step and run successfully.
    After that, I want to import that transformation to pentaho report designer as a data source for my report.
    But, when I import, there is an error as following:
    org.pentaho.di.core.exception.KettleMissingPluginsException:
    Missing plugins found while loading a transformation

    Step : KafkaConsumer


    I had pentaho-kafka-consumer plugin, but i don't know how to add that plugin to pentaho report designer.


    Could anyone please help me to solve this problem.
    Sorry for my bad english.


    Many thanks,
    Hoang Anh.

  2. #2
    Join Date
    Nov 2009
    Posts
    688

    Default

    Place your plugin in ..\report-designer\plugins

  3. #3

    Default

    Quote Originally Posted by johanhammink View Post
    Place your plugin in ..\report-designer\plugins
    Hi johanhammink,

    Thanks for your help.
    I did as you said, but it doesn't work.

    Many thanks,
    Hoang Anh.

  4. #4
    Join Date
    Nov 2009
    Posts
    688

    Default

    I don't know the step KafkaConsumer but this solutions works with orther plugins. With other steps the plugin directory must be placed in the . .\report-designer\plugins and not in .\report-designer\plugins\steps. Perhaps that is the same with the KafkaConsumer step

  5. #5

    Default

    Quote Originally Posted by johanhammink View Post
    I don't know the step KafkaConsumer but this solutions works with orther plugins. With other steps the plugin directory must be placed in the . .\report-designer\plugins and not in .\report-designer\plugins\steps. Perhaps that is the same with the KafkaConsumer step
    Hi johanhammink,


    Thanks your for your help.
    But, there is no subfolder "steps" in my directory: ..\report-designer\plugins
    Below is all subfolders in my directory "..\report-designer\plugins":
    - pentaho-big-data-plugin
    - pentaho-cassandra-plugin
    - pentaho-kafka-consumer
    - pentaho-mongodb-plugin


    I don't know whether more steps are needed?
    Please help me to solve this problem.


    Thanks again for your help,
    Hoang Anh.

  6. #6

    Default

    Quote Originally Posted by johanhammink View Post
    I don't know the step KafkaConsumer but this solutions works with orther plugins. With other steps the plugin directory must be placed in the . .\report-designer\plugins and not in .\report-designer\plugins\steps. Perhaps that is the same with the KafkaConsumer step
    Hi johanhammink,


    That's very wonderful.
    I have just figured out the solution for my problem.
    I create a new subfolder "steps" in my directory "..\report-designer\plugins".
    After that I move the pentaho-kafka-consumer plugin to the new "steps" folder.
    And my problem is solved now.


    Thanks again for your suggestion. It really help me to figure out the solution.


    Thanks and Best Regards,
    Hoang Anh.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.