Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Assign permissions to a Data Source Wizard 'SQL Query' datasource

  1. #1
    Join Date
    Aug 2011
    Posts
    3

    Default Assign permissions to a Data Source Wizard 'SQL Query' datasource

    Hi everybody,
    I have created a new datasource using the Data Source Wizard and selecting the 'SQL Query' option as Source Type.
    If I check my datasources on the 'Manage Data Source' window I see my new datasource with type 'Data Source Wizard'.
    I've also created an Interactive report using this datasource.

    Now I need to assign some permissions to this datasource...

    With classic xml schema files created using Schema Workbench I usually assign permissions using the tecnique explained here (http://mondrian.pentaho.com/document...Access_control) and it works.
    With datasources created with the Data Source Wizard but selecting the 'Database Table(s)' option as Source Type I use the method described here (http://www.howtopentaho.com/securing...uc-datasource/) and it works.

    Unfortunately those two methods seems to be useless with this new datasource.

    If I export this datasource I get a .zip file containing the xml schema and an .xmi file.
    I've tried to modify the xml file adding the permissions and then publishing it with Schema Workbench (after deleting the original datasource from the 'Manage Data Source' window) but what I've obtained is a new datasource with just 'Analysis' type. With this datasource the Interactive report I've created just doesn't work anymore.
    Importing the modified xml file from the 'Manage Data Source' window gave me the same result.
    Saving the new .xml file in the .zip file and the importing it gave me the same result.

    If I try to modify and then publish the .xmi file with Metadata Editor using the method described in the link above I obtain just a 'Metadata' datasource.

    Am I missing something?

    Thank you

    PS: I'm using Pentaho EE 5.4

  2. #2
    Join Date
    Aug 2011
    Posts
    3

    Default

    Quote Originally Posted by clotis81 View Post
    If I export this datasource I get a .zip file containing the xml schema and an .xmi file.
    I've tried to modify the xml file adding the permissions and then publishing it with Schema Workbench (after deleting the original datasource from the 'Manage Data Source' window) but what I've obtained is a new datasource with just 'Analysis' type. With this datasource the Interactive report I've created just doesn't work anymore.
    I tried to not delete the original datasource and the just import the new xml file (with permissions) using the 'Import Analysis...' option from the 'Manage Data Sources' window.
    Now it partially works; an user without the right role can't see the datasource in the analyzer report's datasource list but the datasource is still visible in the interactive report's datasource list.

  3. #3

    Default

    I need information about this:

    " With datasources created with the Data Source Wizard but selecting the 'Database Table(s)' option as Source Type I use the method described here (http://www.howtopentaho.com/securing...uc-datasource/) and it works."

    But link does not works, Somebody can give some information?

    Thanks in advance.

    Best regards.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.