Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Chinese Characters in PDF Export

  1. #1
    Join Date
    Oct 2013
    Posts
    216

    Post Chinese Characters in PDF Export

    Hi,

    I have created one report in which I am using Chinese characters.

    Now when I am using output type = HTML , I can show Chinese characters in output.

    But I am not getting Chinese characters in PDF output.

    I am using PRD version :- 6.0.1.0-386

    I have tried File - configuration - output-pageable-pdf - ~.Encoding = UTF-8 .

    But not work.

    Can anyone tell me how to resolved ?
    -- NITIN --

  2. #2
    Join Date
    Apr 2008
    Posts
    146

    Default 中文在prpt里面 - Chinese in PRPT reports.

    The font you are using does not have UNICODE in it. For example, on my Windows system "Serif" is the default font. It renders fine in PRD preview, but in the PDF it shows up as boxes. I changed it to "Arial Unicode MS" for example and the PDF output started working. You may want to choose the Embed option to make sure no font substitution happens on other people's systems.

    Graphic and prpt included.
    Name:  2016-08-03_12-16-08 -Chinese.jpg
Views: 44
Size:  21.3 KB

    Hope that helps.

    Brandon
    Attached Files Attached Files

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.