Hitachi Vantara Pentaho Community Forums
Results 1 to 1 of 1

Thread: Unable to display measure that have measure expression CDATA query using a dimention

  1. #1
    Join Date
    Sep 2016
    Posts
    1

    Default Unable to display measure that have measure expression CDATA query using a dimension

    Hello,

    I am a new user to schema workbench and have been trying my hand at cube creation and analyzer reports. I am stuck at a point where i have created a measure expression with nested query that goes like
    CASE WHEN Rs_FCT.R_Status_DIM_R_Status_SK in (CASE WHEN R_Status_DIM.R_Status_CD = 'EX' then R_Status_DIM.R_Status_SK END) then Rs_FCT.Rs_SK END

    When I publish the cube I am able to see the measure only when i Drag R_Status_Dim level Status on the report otherwise it throws error but i do not want Dimension Tables Status level displayed on the Analyzer report. I have tried hiding the column in the Analysis report but it removes the column form the report also and i receive the same error

    Here is the Error -
    Oops. There was an error. If this happens again, please contact your Administrator (Message Id: RuntimeException)

    java.util.concurrent.ExecutionException: java.lang.RuntimeException: com.microsoft.sqlserver.jdbc.SQLServerException: The multi-part identifier "R_Status_DIM.R_Status_CD" could not be bound.

    Any kind of help would be appreciated

    Thanks,
    Navodit
    Last edited by Navodit; 09-08-2016 at 08:43 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.