Hitachi Vantara Pentaho Community Forums
Results 1 to 3 of 3

Thread: Cannot connect to Posgres 9.0.2 on PDI v7

  1. #1
    Join Date
    Nov 2013
    Posts
    382

    Thumbs up Cannot connect to Posgres 9.0.2 on PDI v7

    Just trying our first migrations from PDI 4 to PDI 7.0.0.0-25 and we cannot open one of our Posgress databases version 9.0.2, we get the error:

    Error connecting to database: (using class org.postgresql.Driver)
    FATAL: invalid value for parameter "TimeZone": "Europe/Paris"
    We tried both with the (new) Advanced >> Supports the timestamp date type option checked and unchecked. No explicit parameter anywhere on the connection definition.

    There is no problem accessing a Posgress database 9.1.20

    Any idea what are we missing?

    Thks
    Last edited by DepButi; 11-24-2016 at 10:59 AM.

  2. #2
    Join Date
    Nov 2013
    Posts
    382

    Default

    After testing a little while, Postgres 9.0.2 doesn't accept "Europe/Paris" for a " SET TIME ZONE 'Europe/Paris' " sql command, while 9.1.20 does.

    The problem is that we cannot find anywhere a configuration file with this command on the PDI directories, so we don't know who/when issues this specific command.

    Any idea where can we find a Postgres PDI / driver /etc config file with this command?

    Thks

  3. #3
    Join Date
    Nov 2013
    Posts
    382

    Default

    Solved.

    For some unknown reason the Europe/Paris Postgres definition file had wrong access rights so it was not recognised.

    thks
    Last edited by DepButi; 11-24-2016 at 07:30 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.