Hitachi Vantara Pentaho Community Forums
Results 1 to 7 of 7

Thread: PDI 7 does not launch on Mac OS X sierra

  1. #1

    Exclamation PDI 7 does not launch on Mac OS X sierra

    I just installed PDI on my Macbook and moved the data-integration folder into the Applications folder. Now, when I double click on Data Integration, the app simply does not start. I get no error messages.
    I would provide logs, but I'm not sure how to find them.

    Details:
    Mac OS X sierra 10.12.1
    Pentaho Data Integration 7.0.0.0-25

    Any help?

    EDIT:
    support ticket: http://jira.pentaho.com/browse/PDI-15865

    workaround: start spoon.sh from console.

    Thank you in advance.
    Last edited by gutlez; 12-13-2016 at 04:09 PM. Reason: Fixed Link

  2. #2
    Join Date
    Nov 2016
    Posts
    8

    Default

    Hi Thomas



    The link you submitted is empty. Have you tried opening the terminal yet? Sends the log when you try this.
    Student of Informations Systems at UFMS

    Programmer and Data Analisys at BovBI ( http://bovbi.com.br )

    Ponta Porã, MS - Brasil

  3. #3

    Default

    Hi,

    I tried to run the app from terminal, which resulted in the following output:

    thomaskarbe$ open Data\ Integration.app/
    LSOpenURLsWithRole() failed with error -10810 for the file /Applications/data-integration/Data Integration.app.


    About the link: for me it is working. I just tried it again, and it linked me to the bug request in jira.

    Best Regards
    Thomas

  4. #4
    Join Date
    Nov 2016
    Posts
    8

    Default

    Hi, did you try to search on the forums first? Because I had already a thread open for this: http://forums.pentaho.com/showthread...launch-on-OS-X I explained over there that you can launch it by running this command: /Applications/data-integration/Data\ Integration.app/Contents/MacOS/JavaApplicationStub

    I did not create a Jira for that, because I asked in the forums if that was needed/allowed, but I will reply on yours.

  5. #5

    Default

    Hi, I searched indeed, but did not find your post. For now, I simply launch spoon.sh and wait for a solution for the Jira ticket. I will add a link to your thread into the Jira Ticket, too. Might be helpful.

  6. #6

    Default

    FWIW, I had the same issue, but the solution documented here worked for me and was a much cleaner/mac friendly approach.

    http://forums.pentaho.com/showthread...launch-on-OS-X

  7. #7
    Join Date
    Nov 2016
    Posts
    8

    Default

    Yes, this is the exact same thread where I posted the solution. As mentioned before this thread should be closed and marked as duplicate.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.