Hitachi Vantara Pentaho Community Forums
Results 1 to 5 of 5

Thread: Errors starting Report Designer 7 on Ubuntu

  1. #1
    Join Date
    Nov 2016
    Posts
    2

    Default Errors starting Report Designer 7 on Ubuntu

    I have installed 7.0 on Ubuntu 16.04, I start it with report-designer.sh and there are errors in the output. At first I thought they were terminal errors, but if I let the script run long enough, 3-4 minutes, the UI eventually does start and seems to be usable. The first error in the output is:

    Code:
    org.apache.karaf.features.internal.BootFeaturesInstaller - Error installing boot features
    java.lang.Exception: Could not start bundle mvn:org.ops4j.pax.web/pax-web-runtime/3.1.4 in feature(s) pax-http-3.1.4: Unresolved constraint in bundle org.ops4j.pax.web.pax-web-runtime [64]: Unable to resolve 64.0: missing requirement [64.0] osgi.wiring.package;
    I am not necessarily looking for assistance as it does start eventually. Just reporting the issue in case others come across it.

    System: Ubuntu 16.04, java-8-oracle
    Attached Files Attached Files

  2. #2

    Lightbulb

    Quote Originally Posted by daemmon View Post
    I have installed 7.0 on Ubuntu 16.04, I start it with report-designer.sh and there are errors in the output. At first I thought they were terminal errors, but if I let the script run long enough, 3-4 minutes, the UI eventually does start and seems to be usable. The first error in the output is:

    Code:
    org.apache.karaf.features.internal.BootFeaturesInstaller - Error installing boot features
    java.lang.Exception: Could not start bundle mvn:org.ops4j.pax.web/pax-web-runtime/3.1.4 in feature(s) pax-http-3.1.4: Unresolved constraint in bundle org.ops4j.pax.web.pax-web-runtime [64]: Unable to resolve 64.0: missing requirement [64.0] osgi.wiring.package;
    I am not necessarily looking for assistance as it does start eventually. Just reporting the issue in case others come across it.

    System: Ubuntu 16.04, java-8-oracle
    If you see Pentaho compatibility document.
    You can recognise Pentaho 7 compatible with Ubuntu Server 12.04 LTS & 14.04 LTS.
    So, maybe ubuntu 16 will cause.

  3. #3
    Join Date
    Mar 2015
    Posts
    1

    Default

    I also got similar errors on OS X 10.11.6. And report designer opens very late.
    I disabled some features in the "system/karaf/etc/org.apache.karaf.features.cfg" file like below:

    #featuresBoot=config,kar,http,war,pentaho-client-minimal,pentaho-big-data-plugin-testless-osgi,pdi-dataservice-client,community-edition
    featuresBoot=config,pentaho-client-minimal,community-edition

    Now report designer opens without any error and lag.

  4. #4

    Default

    I'm facing the same issue. I've just unpacked "prd-ce-7.0.0.0-25" on my machine: Win7 x64, Java(TM) SE Runtime Environment (build 1.8.0_111-b14). Then I started the designer, but I've noticed it took ~2min of the UI to show up. A quick check of the "prd.log" file shows the same error :
    Code:
    2017-03-21 13:59:12,594 [   7164]  ERROR - org.apache.karaf.features.internal.BootFeaturesInstaller - Error installing boot features
    java.lang.Exception: Could not start bundle mvn:org.ops4j.pax.web/pax-web-runtime/3.1.4 in feature(s) pax-http-3.1.4: Unresolved constraint in bundle org.ops4j.pax.web.pax-web-runtime [64]: Unable to resolve 64.0: missing requirement [64.0] osgi.wiring.package; (&(osgi.wiring.package=javax.servlet.resources)(version>=2.3.0)(!(version>=3.1.0)))
        at org.apache.karaf.features.internal.FeaturesServiceImpl.startBundle(FeaturesServiceImpl.java:504)
        at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:459)
        at org.apache.karaf.features.internal.BootFeaturesInstaller.installBootFeatures(BootFeaturesInstaller.java:92)
        at org.apache.karaf.features.internal.BootFeaturesInstaller$1.run(BootFeaturesInstaller.java:71)
    Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.web.pax-web-runtime [64]: Unable to resolve 64.0: missing requirement [64.0] osgi.wiring.package; (&(osgi.wiring.package=javax.servlet.resources)(version>=2.3.0)(!(version>=3.1.0)))
        at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4002)
        at org.apache.felix.framework.Felix.startBundle(Felix.java:2045)
        at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:976)
        at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:963)
        at org.apache.karaf.features.internal.FeaturesServiceImpl.startBundle(FeaturesServiceImpl.java:501)
        ... 3 more
    P.S. I've just created a JIRA about this: http://jira.pentaho.com/browse/PRD-5877
    Last edited by veskojl; 03-21-2017 at 08:52 AM.

  5. #5

    Default

    By the method of elimination I've found the problem is related to the "war" feature, so one can just leave it out.
    Code:
    featuresBoot=config,kar,http,pentaho-client-minimal,pentaho-big-data-plugin-testless-osgi,pdi-dataservice-client,community-edition

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.