Hitachi Vantara Pentaho Community Forums
Results 1 to 4 of 4

Thread: Calculator and Remove CRLF from string seems not to work as expected

  1. #1
    Join Date
    Oct 2011
    Posts
    17

    Default Calculator and Remove CRLF from string seems not to work as expected

    I'm reading a file with CRLF in fields (coming from JIRA database), but I'd like to remove the CRLF from the filed (content), so I'm using the CALCULATOR with the appropiate calculation (at least to my opnion), but the results are strange, so what I'm doing not correctly

    Field Input (CRLF put in bold by ME, for display purposes:
    "Mark mentioned that this issue is not blocking for delivering 8.1.1 to Investec for phase one of the implementation. Therefore this is not a must have for 8.1.1 and we can deliver this in 8.2 or 8.3. I prefer to deliver it asap, so in 8.2 Will discuss with both teams if it can be delivered in 8.2-RC4.
    CRLF
    Added the Story"

    Result field:
    B@5c947618

    any help is appreciated.Name:  Remove CRLF.jpg
Views: 90
Size:  20.3 KB

  2. #2
    Join Date
    Jun 2012
    Posts
    5,534

    Default

    The problem comes from your Input step (CSV-Input?).
    You must turn off option "Lazy conversion".
    So long, and thanks for all the fish.

  3. #3
    Join Date
    Aug 2011
    Posts
    236

    Default

    Hi Michiel,

    Have you tried use the component 'String Operations? That has a specific option for CR/LF removal.

    HTH
    PDI 8.0.0
    MySQL - 5.6.27
    Redshift - 1.0.1485
    PostgreSQL 8.0.2
    OS - Ubuntu 10.04.2

  4. #4
    Join Date
    Oct 2011
    Posts
    17

    Default

    Marabu and tnewman

    Both option seems to do the trick.

    Thanks,

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.