Hitachi Vantara Pentaho Community Forums
Results 1 to 2 of 2

Thread: Exception: com.jcraft.jsch.JSchException

  1. #1

    Red face Exception: com.jcraft.jsch.JSchException

    Hi all.

    I am trying to use the SFTP step to put some files into a server.

    I tested my connection from within a DOS window with psftp.exe and it worked fine. And form WINSCP also worked fine.

    But when I insert the parameters into the Pentaho step SFTP, I got the following message:
    Error trying to connect to xxx.xxx.xxx.xxx. Exception: com.jcraft.jsch.JSchException: Auth cancel Auth cancel.
    Error connection on xxx.xxx.xxx.xxx

    Any idea ?

    Thanks in advance.

    Guillermo
    Buenos Aires, Argentina

  2. #2
    Join Date
    Jun 2012
    Posts
    5,534

    Default

    With simple authentication (username/password), if you give a wrong password, the message should be "Auth fail".
    If you don't give a password at all you should see "Auth cancel".
    It's the same with strong authentication (keyfiles) I guess.
    So long, and thanks for all the fish.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Privacy Policy | Legal Notices | Safe Harbor Privacy Policy

Copyright © 2005 - 2019 Hitachi Vantara Corporation. All Rights Reserved.